Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156895 - SELinux breaks TeamSpreak2RC2
Summary: SELinux breaks TeamSpreak2RC2
Keywords:
Status: CLOSED DUPLICATE of bug 151870
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL: http://www.goteamspeak.com/
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 22:46 UTC by Roy
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-05 20:28:41 UTC


Attachments (Terms of Use)

Description Roy 2005-05-04 22:46:46 UTC
Description of problem:
SELinux breaks Teamspeak. Teamspeak doesn't work with SELinux enabled. After
giving a setenforce 0 it does start and work properly.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.23.14-2

How reproducible:
Start Teamspeak with SELinux-targeted on.
  
Actual results:
Teamspeak fails to start with message 
/usr/local/TeamSpeak2RC2/TeamSpeak.bin: symbol lookup error:
/usr/local/TeamSpeak2RC2/TeamSpeak.bin: undefined symbol: initPAnsiStrings

Expected results:
Teamspeak starting properly

Comment 1 Daniel Walsh 2005-05-05 11:40:19 UTC
Do you see any avc messages in /var/log/messages or /var/log/audit/audit.log?

What kind of file is TeamSpeak.bin?

Dan

Comment 2 Roy 2005-05-05 13:25:53 UTC
In /var/log/messages I get the message:
May  5 15:23:18 Seven kernel: audit(1115299398.453:0): avc:  denied  { execmod }
for  path=/usr/local/TeamSpeak2RC2/libborqt-6.9-qt2.3.so dev=hda3 ino=2131888
scontext=root:system_r:unconfined_t tcontext=root:object_r:usr_t tclass=file

/var/log/audit/audit.log does not exist.

TeamSpeak.bin is the binary, started by the script called TeamSpeak

Comment 3 Daniel Walsh 2005-05-05 19:05:52 UTC
Try 
chcon -t shlib_t /usr/local/TeamSpeak2RC2/*.so
chcon -t texrel_shlib_t /usr/local/TeamSpeak2RC2/libborqt-6.9-qt2.3.so



Comment 4 Roy 2005-05-05 20:28:41 UTC
That does indeed fix the problem with Teamspeak, and the problem I had with the
Flash plugin, so something is defining libraries wrongly upon creation I
guess... I don't think normal users would like that, but that does make this
report a duplicate of 151870

*** This bug has been marked as a duplicate of 151870 ***


Note You need to log in before you can comment on or make changes to this bug.