Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156884 - system-config-bind crash at start.
Summary: system-config-bind crash at start.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-bind
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 21:35 UTC by Frank Büttner
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 4.0.0-14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-05 08:20:42 UTC


Attachments (Terms of Use)

Description Frank Büttner 2005-05-04 21:35:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
When i will start system-config-bind-4.0.0-11 it crash with the error below.

Version-Release number of selected component (if applicable):
system-config-bind-4.0.0-11

How reproducible:
Always

Steps to Reproduce:
1. try to start  system-config-bind 

Actual Results:  the app crash

Expected Results:  running app

Additional info:

This is the error:
system-config-bind

(bindconf:9784): libglade-WARNING **: unknown property `focus_on_map' for class `GnomeApp'

(bindconf:9784): libglade-WARNING **: unknown property `hover_selection' for class `GtkTreeView'

(bindconf:9784): libglade-WARNING **: unknown property `hover_expand' for class `GtkTreeView'

(bindconf:9784): libglade-WARNING **: unknown property `focus_on_map' for class `GnomeAbout'

(bindconf:9784): libglade-WARNING **: unknown property `focus_on_map' for class `GtkDialog'

(bindconf:9784): libglade-WARNING **: unknown property `hover_selection' for class `GtkTreeView'

(bindconf:9784): libglade-WARNING **: unknown property `hover_expand' for class `GtkTreeView'

(bindconf:9784): libglade-WARNING **: unknown property `ellipsize' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `width_chars' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `single_line_mode' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `angle' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `ellipsize' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `width_chars' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `single_line_mode' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `angle' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `ellipsize' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `width_chars' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `single_line_mode' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `angle' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `ellipsize' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `width_chars' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `single_line_mode' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `angle' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `ellipsize' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `width_chars' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `single_line_mode' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `angle' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `hover_selection' for class `GtkTreeView'

(bindconf:9784): libglade-WARNING **: unknown property `hover_expand' for class `GtkTreeView'

(bindconf:9784): libglade-WARNING **: unknown property `ellipsize' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `width_chars' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `single_line_mode' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `angle' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `ellipsize' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `width_chars' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `single_line_mode' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `angle' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `ellipsize' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `width_chars' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `single_line_mode' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `angle' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `ellipsize' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `width_chars' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `single_line_mode' for class `GtkLabel'

(bindconf:9784): libglade-WARNING **: unknown property `angle' for class `GtkLabel'
Traceback (most recent call last):
  File "/usr/sbin/system-config-bind", line 191, in ?
    GUI(sys.argv)
  File "/usr/sbin/system-config-bind", line 91, in __init__
    self.bind=BIND(self, argv)
  File "/usr/share/system-config-bind/BIND.py", line 84, in __init__
    self.load()
  File "/usr/share/system-config-bind/BIND.py", line 99, in load
    for origin, real_key, filename, clas, cfg, view in self.nmdc.zones():
  File "/usr/share/system-config-bind/NamedConf.py", line 64, in zones
    yield([self.zone_origin(z), z, self.zone_file(z), self.zone_class(z), objs['zone'][z], None])
  File "/usr/share/system-config-bind/NamedConf.py", line 50, in zone_file
    file=chrd+self.objs['options']['directory'].strip('"')+'/'+file
KeyError: 'options'

Comment 1 Peter Lawler 2005-05-04 22:02:06 UTC
yup, pretty much the same here. libglade warnings then python collapse.

Comment 2 Jason Vas Dias 2005-05-05 16:21:33 UTC
It seems the system-config-bind.glade file was generated on FC4 .
When you run s-c-b from the GUI, you don't get the glade warnings.

Also, it was unable to deal with named.conf files that do not contain
an "options { ... };" clause. The default initial configuration as 
installed by s-c-b or caching-nameserver contains an options clause.

This has now been rectified with system-config-bind-4.0.0-12 - the
glade file has been regenerated for FC-3, and s-c-b will deal
correctly with named.conf files that do not contain an options 
clause . 

s-c-b-4.0.0-12 is now being pushed to FC-3 updates, and also can be
downloaded from:
http://people.redhat.com/~jvdias/system-config-bind/system-config-bind-4.0.0-12.noarch.rpm


Comment 3 Peter Lawler 2005-05-05 21:19:39 UTC
Libglad errors gone. Now I'm getting:

 Traceback (most recent call last):
  File "/usr/sbin/system-config-bind", line 191, in ?
    GUI(sys.argv)
  File "/usr/sbin/system-config-bind", line 91, in __init__
    self.bind=BIND(self, argv)
  File "/usr/share/system-config-bind/BIND.py", line 84, in __init__
    self.load()
  File "/usr/share/system-config-bind/BIND.py", line 108, in load
    zone = Zone(filename, origin, self.nmdc, parent + [ real_key ], clas,
cfg['type'])
  File "/usr/share/system-config-bind/Zone.py", line 366, in __init__
    self.load(continuation==None)
  File "/usr/share/system-config-bind/Zone.py", line 166, in load
    self.read()
  File "/usr/share/system-config-bind/Zone.py", line 150, in read
    self.parse()
  File "/usr/share/system-config-bind/Zone.py", line 100, in parse
    debug( 'RR TYPE: ', rr.Type() )
AttributeError: 'int' object has no attribute 'Type'


Comment 4 Frank Büttner 2005-05-05 21:24:51 UTC
after updatting to version system-config-bind-4.0.0-12.noarch.rpm all is ok.

Comment 5 Jason Vas Dias 2005-05-05 22:07:04 UTC
(In reply to comment #3)
system-config-bind is finding out-of-zone data in a zone file.

out-of-zone data are records with name labels that are not suffixed by 
the zone origin. It would be helpful if you could send me your zone
files or append them to this bug so I could test with them 
( # tar -cpf - /var/named | gzip > zone.tar.gz
  and then send me zone.tar.gz or append it to this bug.
) 

Normally, s-c-b would report out-of-zone data in a "warning" dialog
- if it were not for the 
  debug( 'RR TYPE: ', rr.Type() )
on line 100, which I must have put in there and forgot about after
testing the out-of-zone data detection functionality :(

Removing that line will show you the out-of-zone data and allow s-c-b to
proceed. 
You can download a new version with the fix from:
http://people.redhat.com/~jvdias/system-config-bind/system-config-bind-4.0.0-14.noarch.rpm



Comment 6 Peter Lawler 2005-05-05 22:13:37 UTC
Due to personal sensitivities, I'll send the tarball via email. Yes, it's not a
100% clean setup. I'd kinda hoped SCB would handle it, but obviously not. At
least it's a good real world test :-)

Comment 7 Peter Lawler 2005-05-05 22:28:53 UTC
Just had a play with -14. Looks good. FWIW, if I try to exit, it prompts me 'do
you want to save' and 'are you sure'. The defaults for both these questions are
'Yes'. I prefer defaults like that being 'No', but that's just my personal
preference.


Note You need to log in before you can comment on or make changes to this bug.