Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156869 - DISPLAY error msg anytime bluepin is run
Summary: DISPLAY error msg anytime bluepin is run
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez-utils
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 19:58 UTC by Carmine Greco
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-09 16:53:41 UTC


Attachments (Terms of Use)

Description Carmine Greco 2005-05-04 19:58:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
Symptom: cell phone could not connect to Thinkpad T42p over Bluetooth
I started breaking down the steps for connecting a Bluetooth device to the Thinkpad and found out that neither the pin_helper nor dbus_pin_helper were working to give hcid a PIN when my cellphone was trying to connect.






Version-Release number of selected component (if applicable):
bluez-utils-2.15-5

How reproducible:
Always

Steps to Reproduce:
1) Use Fn+F5 to enable Thinkpad Bluetooth device
2) Run "hciconfig hci0 up"
3) Start bluetooth service ("service bluetooth start")
4) Test out /usr/bin/bluepin to see what it will give hcid upon execution since /etc/bluetooth/hcid.conf has "security user" enable by default.
  

Actual Results:  $ bluepin
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Traceback (most recent call last):
  File "/usr/bin/bluepin", line 39, in ?
    import gtk
  File "/usr/src/build/535819-i386/install/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 37, in ?
RuntimeError: could not open display


Expected Results:  Popup dialog for me to enter a PIN, followed by "PIN:"+ my PIN on stdout.

Additional info:

Workaround:
1) Store PIN in /etc/bluetooth/pin
2) Change /etc/bluetooth/hcid.conf to use "security auto"

Comment 1 Christoph Wickert 2005-07-05 12:47:00 UTC
The above error message is normal if you call bluepin from the commandline as
normal user, bluepin has to be called by root with 2 arguments: First is "dir" 
and second bluetooth device address.

With bluez-utils-2.15-7 at least pin_helper works, on incoming/outgoing
connections I'm asked for a pin, so I think this one should be closed as "not a
bug".

dbus_pin_helper still does not work (see #160676).


Note You need to log in before you can comment on or make changes to this bug.