Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156860 - Initializing hardware freeze
Summary: Initializing hardware freeze
Keywords:
Status: CLOSED DUPLICATE of bug 156862
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 19:05 UTC by Michael A. Peters
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-05 05:50:53 UTC


Attachments (Terms of Use)

Description Michael A. Peters 2005-05-04 19:05:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
During boot, freezes after udev at

Initializing hardware...

I've seen a couple fc3 bugs to this effect, but mine is a little different - it never gets to

storage network audio

Those have not been echoed at time of freeze.

kernel 2.6.11-1.1275_FC4 does in fact work.

IBM Thinkpad T20 700MHz 256 MB bios revision 1.22

default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
#hiddenmenu
password --md5 *snip*
title Fedora Core (2.6.11-1.1284_FC4)
        root (hd0,0)
        kernel /vmlinuz-2.6.11-1.1284_FC4 ro root=/dev/VolGroup00/LogVol00 acpi=force quiet
        initrd /initrd-2.6.11-1.1284_FC4.img
title Fedora Core (2.6.11-1.1275_FC4)
        root (hd0,0)
        kernel /vmlinuz-2.6.11-1.1275_FC4 ro root=/dev/VolGroup00/LogVol00 acpi=force quiet
        initrd /initrd-2.6.11-1.1275_FC4.img

00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:03.0 Communication controller: Agere Systems (former Lucent Microelectronics) WinModem 56k (rev 01)
00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/IX-MV (rev 11)
02:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)



Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1284_FC4

How reproducible:
Always

Steps to Reproduce:
1. Try to boot
2.
3.
  

Actual Results:  does not get very far

Expected Results:  system should boot

Additional info:

Comment 1 Bill Nottingham 2005-05-05 04:24:51 UTC
Do you have SELinux enabled, and does it work if you boot with
enforcing=0 or selinux=0?

Comment 2 Fred New 2005-05-05 04:56:10 UTC
I'm having the same problem on my Pentium III 800 MHz system.  I'll try
enforcing=0 in a moment:

grub.conf:
title Fedora Core (2.6.11-1.1284_FC4)
        root (hd0,0)
        kernel /vmlinuz-2.6.11-1.1284_FC4 ro root=LABEL=/12 quiet
        initrd /initrd-2.6.11-1.1284_FC4.img

lspci:
00:00.0 Host bridge: Intel Corporation 82815 815 Chipset Host Bridge and Memory
Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82815 815 Chipset AGP Bridge (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801BA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801BA IDE U100 (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #1) (rev 02)
00:1f.3 SMBus: Intel Corporation 82801BA/BAM SMBus (rev 02)
00:1f.4 USB Controller: Intel Corporation 82801BA/BAM USB (Hub #2) (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio
(rev 02)
01:08.0 Ethernet controller: Intel Corporation 82801BA/BAM/CA/CAM Ethernet
Controller (rev 01)
02:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS

Comment 3 Fred New 2005-05-05 05:10:53 UTC
It boots with enforcing=0. I still see
Starting udev: MAKEDEV: mkdir: File exists
                      [  OK  ]
Initializing hardware...

but it continues ahead instead of hanging.

But going back to the hanging system - the keyboard is still active; I can turn
the NumLock LED on and off.  But Ctrl-Alt-Delete doesn't work at this point.

Comment 4 Alexandre Oliva 2005-05-05 05:50:53 UTC

*** This bug has been marked as a duplicate of 156862 ***

Comment 5 Henry Franco 2005-08-20 22:46:38 UTC
I'm pretty new to Linux.  How would I boot enforcing=0. 

Comment 6 Charlie Altman 2005-10-05 12:01:39 UTC
(In reply to comment #5)
> I'm pretty new to Linux.  How would I boot enforcing=0. 

Just modify the kernel arguments at startup. When grub comes up, select the OS
to boot and hit "a", then make the kernel line something like this;

kernel /vmlinuz-2.6.11-1.1284_FC4 ro root=LABEL=/12 enforcing=0 quiet


Note You need to log in before you can comment on or make changes to this bug.