Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156853 - evolution-data-server does not exit when user logs out
Summary: evolution-data-server does not exit when user logs out
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution-data-server
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard: RHEL4U3NAK
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 18:10 UTC by Eric Jones
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-13 17:32:43 UTC


Attachments (Terms of Use)

Description Eric Jones 2005-05-04 18:10:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Red Hat/1.0.3-1.4.1 Firefox/1.0.3

Description of problem:
There are several related bugs for different releases, including https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=134851.  Basically when the user logs out after having used evolution, two processes remain running, evolution-data-server and bonobo-activation-server.  These two processes are also fairly large memory users (right now e-d-s is using 379 MB, which seems high for its purpose).  Either way, this is a large program to keep resident after gnome has exited.  

Version-Release number of selected component (if applicable):
evolution-data-server-1.0.2-4

How reproducible:
Always

Steps to Reproduce:
1. Log in to gnome
2. Execute evolution
3. Log out of gnome
4. ps -ef | grep evolution

Actual Results:  evolution-data-server-1.0 was still running

Expected Results:  evolution-data-server should have exited gracefully.

Additional info:

Comment 1 Dave Malcolm 2005-05-12 23:21:48 UTC
Does bonobo-activation-server hang around as well?

Note that you may have to wait up to 10 seconds for both processes to go away
after logout.

Comment 2 Eric Jones 2005-05-12 23:59:31 UTC
yes, i've been logged out for two days now and there are instances of gnome-
keyring-daemon, artsd, evolution-data-server, bonbo-activation-server, and ssh-
agent, and gconfd-2.  I know the ssh-agent is another bug that has been filed 
several times.

Comment 6 Dave Malcolm 2005-06-25 00:32:06 UTC
Thanks for this information.

In the original report, you refer to evolution-data-server and
bonobo-activation-server outliving the user's session.
In comment #2, there seem to additionally be some other processes:
gnome-keyring-daemon, artsd, and gconfd-2 (with ssh-agent filed as another bug). 

(I believe we squashed all of these bugs separately before RHEL4 release, so it
may be that you're running into an unforeseen general bug with session handling
of which the b-a-s and e-d-s lifetime issues are just symptoms)

To track down the specifics of the e-d-s and b-a-s lifetimes, please try the
following:
(i) ensure all the stray processes from the last session are killed
(ii) add "export BONOBO_ACTIVATION_DEBUG_OUTPUT=1' to /etc/X11/gdm/Sessions/Default
(iii) log in and use evolution
(iv) log out and wait 15 seconds
(v) check what processes are still around
The file ~/.xsesssion-errors should now contain useful debugging information
concerning evolution-data-server and bonobo-activation-server.  Please attach a
copy to this bug.

Thanks.

Comment 9 Daniel Riek 2006-03-13 17:32:43 UTC
Due to the low impact of this request on our broader customer base the priority
of this is low. Given the sheer number of requests for RHEL Update releases, our
resource constraints, and the fact that there are no or only few other requests
for this component, it is more than unlikely that we will be able to deliver on
this in any RHEL Update release.

For further details on the RHEL Update criteria please see
http://intranet.corp.redhat.com/ic/intranet/RHELUpdateCriteria.html

Clearing ACKs and closing WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.