Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156852 - rhn_check tracebacks updating RHEL3 U1 machine to latest errata
Summary: rhn_check tracebacks updating RHEL3 U1 machine to latest errata
Keywords:
Status: CLOSED DUPLICATE of bug 130169
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 18:06 UTC by Brent Fox
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-11 10:50:15 UTC


Attachments (Terms of Use)

Description Brent Fox 2005-05-04 18:06:42 UTC
I did an install of RHEL3 Update 1 and skipped RHN registration in firstboot. 
After rebooting, I registered the machine with RHN but did not apply any errata.
 Then I went to the RHN web UI and scheduled all relevant errata to be sent to
the machine.  Then I ran rhn_check on the client.

It installed many errata and then tracebacked at the following point:

Installing...
   1:up2date                ########################################### [100%]
   2:up2date-gnome          ########################################### [100%]
New Up2date available
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 332, in ?
    try:
  File "/usr/sbin/rhn_check", line 209, in handle_action
     
  File "/usr/sbin/rhn_check", line 164, in run_action
    except:
  File "/usr/sbin/rhn_check", line 92, in do_call
     
  File "/usr/share/rhn/actions/errata.py", line 58, in update
    return packages.update(packagelist)
  File "/usr/share/rhn/actions/packages.py", line 357, in update
    # run the method, but move all the exception catching
  File "/usr/share/rhn/actions/packages.py", line 193, in _catchErrors
     
  File "/usr/share/rhn/actions/packages.py", line 396, in batchRun
    if pkgList:
  File "wrapper.py", line 1085, in batchRun
up2date_client.up2dateErrors.Up2dateNeedsUpdateError


Now I cannot open the RPM database.  I assume that removing the __db.00* files
in /var/lib/rpm will fix that, but I want to understand what went wrong in the
first place.

Comment 1 Clifford Perry 2005-05-11 10:50:15 UTC

*** This bug has been marked as a duplicate of 130169 ***


Note You need to log in before you can comment on or make changes to this bug.