Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156851 - KDE blacklists gcc4
Summary: KDE blacklists gcc4
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 17:52 UTC by Sammy
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-05 02:02:10 UTC


Attachments (Terms of Use)

Description Sammy 2005-05-04 17:52:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.0 (like Gecko)

Description of problem:
I just updated kdelibs from the KDE_3_4_BRANCH (which I occasionally do) 
and tried to build a new rpm from the Fedora devel spec file. The configure 
crashed by a long message explaining that gcc-4.0.0 was blacklisted because 
it miscompiles KDE that causes crashes. 
 
What does this mean for KDE in FC4?  
 
I am experiencing very few crashes in what I use in KDE. The ones I know now 
are the crash of knotify and artsd with the new alsa-lib-1.0.9rc's. This bug is 
reported as an alsa bug with some additional non KDE problems that may have 
been fixed. But the KDE part has not been fixed. 
 
Some applications (not in Fedora) do have problems when compiled 
with gcc-4 (like xine-ui crashes when one right-clicks the mouse) but they work 
fine when compiled with gcc-3.4. 
 
Overall, I find KDE very stable with gcc-4.0 and wonder what prompted this warning. 
Anyway, I have created a patch to remove the blacklisting and am compiling kdelibs. 
We shall see. 

Version-Release number of selected component (if applicable):
kdelibs-3.4.0-cvs

How reproducible:
Always

Steps to Reproduce:
1. update kdelibs from KDE_3_4_BRANCH 
2. try to rebuild the rpm 
3. 
   

Additional info:

Comment 1 Rahul Sundaram 2005-09-05 02:02:10 UTC
Upstream KDE has blacklisted GCC 4 since it miscompiled it. However Fedora's
version of GCC and KDE in FC4 contains patches will fix these issues. When the
subsequent new release of GCC and KDE is made these patches are likely to be
integrated within them. 

Note that Fedora Core 4 also ships with a previous version of GCC for
compatibility reasons. For other packages using the prebuilt binaries in the
Fedora repositories is recommended. 




Note You need to log in before you can comment on or make changes to this bug.