Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156849 - kernel-smp chosen as default kernel for UP i686
Summary: kernel-smp chosen as default kernel for UP i686
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 17:39 UTC by Alexandre Oliva
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-05 00:53:07 UTC


Attachments (Terms of Use)

Description Alexandre Oliva 2005-05-04 17:39:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
A FC4-re0503.0 install on an old Dell Inspiron 8000 with a PIII 1.0GHz processor (single processor, no HT) gets not only the kernel-smp package installed, which was never installed before, but also has that kernel enabled by default.  This feels wrong.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run a fresh `everything' install on an old i686 notebook

Actual Results:  kernel-smp is installed, and chosen as the default kernel

Expected Results:  that's pointless, the UP kernel should be more efficient.  There's little point in even installing the SMP kernel.  Earlier releases didn't install it.

Additional info:

Comment 1 Jeremy Katz 2005-05-04 17:55:27 UTC
Not seeing this here on the UP box we have lying around.  Can you run

PYTHONPATH=/usr/lib/anaconda python -c 'import isys; print isys.htavailable()'
PYTHONPATH=/usr/lib/anaconda python -c 'import isys; print isys.smpAvailable()'

on the machine?  

Comment 2 Alexandre Oliva 2005-05-04 19:43:36 UTC
Zero for both, after booting up after install.  I'll try that again within the
installer, as soon as I manage to burn a CD again.  The box that has the CD
image and the CD burner is running a broken kernel, and I'm waiting for updates
to complete to reboot it.

Comment 3 Jeremy Katz 2005-05-04 19:48:40 UTC
And are you sure you're not using a ks.cfg that has kernel-smp explicitly listed
here?  Only since I've been bitten by that a couple of times :)

Comment 4 Alexandre Oliva 2005-05-04 20:32:07 UTC
Same thing in the installer's VT2.  I couldn't find any indication whatsoever in
the install logs that it was going to choose the smp kernel.  In fact, it even
excluded kernel-smp-devel and kernel-xen*-devel from the install, but still
installed the smp and the xen kernels.  Could this be because of some dependency
on kernel by some other package?  (all kernels provide kernel)  This doesn't
explain why the smp kernel would have been chosen as the default, but...

No kernel-smp in the ks file (just checked again).  In fact, the
anaconda-generated post-install ks file lists kernel, not kernel-smp.

This is an `@Everything' ks install, in case it makes a difference.  This could
bring in additional kernels because of the kernel modules that are now in the tree.

Comment 5 Jeremy Katz 2005-05-05 00:53:07 UTC
*sigh*  Yep, that's it.  I forgot about them.  Added to the list for now. 
Longer term, need to think of a better way of handling this as its entirely too
manual and error-prone atm.


Note You need to log in before you can comment on or make changes to this bug.