Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156829 - libgnomeui backtrace after upgrade
Summary: libgnomeui backtrace after upgrade
Alias: None
Product: Fedora
Classification: Fedora
Component: libgnomeui
Version: 4
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2005-05-04 15:35 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-07-06 09:21:48 UTC

Attachments (Terms of Use)
backtrace (deleted)
2005-05-04 15:36 UTC, Need Real Name
no flags Details

Description Need Real Name 2005-05-04 15:35:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Epiphany/1.6.1

Description of problem:
I ran an yum upgrade today, and on queue, epiphany crashed.
I tried to get a backtrace with bugbuddy, but the gedit window containing the paste dispappeared. Perhaps accidentally closed, perhaps crashed too.

Normally, if epiphany crashes during a yum upgrade, evolution does too. There was a longer gap between the two this time, so not certain the upgrade caused it.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Additional info:

Comment 1 Need Real Name 2005-05-04 15:36:16 UTC
Created attachment 114020 [details]

bugbuddy backtrace from evolution's crash

Comment 2 Need Real Name 2005-05-05 16:24:12 UTC
epiphany and gedit both crashed after an upgrade:
Backtrace was generated from '/usr/bin/epiphany'

Using host libthread_db library "/lib/".
0x00cc5402 in ?? ()
#0  0x00cc5402 in ?? ()
#1  0x00caffdb in ?? ()
#2  0x0578c214 in ?? () from /usr/lib/
#3  0x00000000 in ?? ()

gedit (I don't have gedit-debuginfo installed):
0x00c80402 in ?? ()
#0  0x00c80402 in ?? ()
#1  0x00caffb3 in ?? ()
#2  0x0578c214 in ?? () from /usr/lib/
#3  0x0574f080 in libgnomeui_module_info_get () from /usr/lib/
#4  <signal handler called>
#5  0x00c80402 in ?? ()
#6  0x00a7c12c in ?? ()
#7  0x00b77ff4 in ?? ()
#8  0x00000000 in ?? ()

Comment 3 Dave Malcolm 2005-05-12 20:23:02 UTC
Thanks for the report.  From the evolution backtrace it looks like an assertion
failed in thread 1 inside gtk_container_propagate_expose ; it probably printed
something as it died (which you won't have seen unless you launched Evolution
from a terminal).

More that that I can't say without the debuginfo package (for more information

I'm not sure how stable we're expecting the UI to be whilst various components
of itself are being upgraded.  Reassigning to owner of libgnomeui, though
without more information on reproducing the bug it's going to be difficult to
fix.  Which versions of evolution, of gtk2, libgnomeui etc, both before and
after the update?

Comment 4 Need Real Name 2005-05-12 20:47:40 UTC
It's happened during probably half of the yum upgrades I've done.
Before an upgrade, I always make sure I have evolution and epiphany open. They
always crash at some point after an upgrade.

Previous upgrades have always been stable during an upgrade. Not being stable
would make the system unusable. I'd have to restart X or go into text mode to
run an upgrade.

Which of the debuginfo packages should I install? There are lots :)

Comment 5 Need Real Name 2005-07-06 09:21:48 UTC
Closing. No activity for two months.

Note You need to log in before you can comment on or make changes to this bug.