Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156827 - [PATCH] building kernel is not successfull during linking stage
Summary: [PATCH] building kernel is not successfull during linking stage
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Jason Baron
QA Contact: Brian Brock
URL:
Whiteboard:
: 156830 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 15:23 UTC by Alexander Suvorov
Modified: 2013-03-06 05:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-23 20:37:48 UTC


Attachments (Terms of Use)
patch to fix definition of page_is_ram() function (deleted)
2005-05-04 15:34 UTC, Alexander Suvorov
no flags Details | Diff

Description Alexander Suvorov 2005-05-04 15:23:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:1.7.6) Gecko/20050322 Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
There is a little bug in kernel sources that prevents to build kernel successfully with enabling crash module ().

I test only i386 platform, but probably it exists on x86_64 and mips platforms because of identical definition of page_is_ram function.



Version-Release number of selected component (if applicable):
kernel-2.6.9-5.0.3.EL.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. enable crash as module or built-in
2. run make 
3. got error message
  

Actual Results:  ...
  LD      init/built-in.o
  LD      .tmp_vmlinux1
drivers/built-in.o(.text+0x4cc4d): In function `crash_read':
include/asm/crash.h:42: undefined reference to `page_is_ram'
make: *** [.tmp_vmlinux1] Error 1

Expected Results:  linking ok


Additional info:

I attached a little patch to fix this bug

Comment 1 Alexander Suvorov 2005-05-04 15:34:33 UTC
Created attachment 114019 [details]
patch to fix definition of page_is_ram() function

Comment 2 Suzanne Hillman 2005-05-04 19:59:19 UTC
*** Bug 156830 has been marked as a duplicate of this bug. ***

Comment 4 Jason Baron 2011-11-23 20:37:48 UTC
we don't support re-compiling the kernel in different ways. closing.


Note You need to log in before you can comment on or make changes to this bug.