Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156776 - ifup hangs during bootup
Summary: ifup hangs during bootup
Keywords:
Status: CLOSED DUPLICATE of bug 156862
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 08:03 UTC by Ingo Molnar
Modified: 2014-03-17 02:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-05 15:36:39 UTC


Attachments (Terms of Use)

Description Ingo Molnar 2005-05-04 08:03:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
after a yum update roughly 4 days ago, my box couldnt boot up anymore. It brings up eth1 but then the ifup of an xDSL interface hangs indefinitely (for hours if left alone). Booting via init=/bin/bash and fixing up the interface to not be brought up during bootup solves the problem - 'ifup Provider' works fine after a full bootup. The problem is fully reproducible otherwise.

i'm now running yesterday's devel packages and the problem didnt go away.


Version-Release number of selected component (if applicable):
initscripts-8.10-1

How reproducible:
Always

Steps to Reproduce:

  

Additional info:

Comment 1 Bill Nottingham 2005-05-04 16:25:50 UTC
If you add -x to the invocation of ifup, where does it hang?

Comment 2 Ingo Molnar 2005-05-05 08:55:54 UTC
things further deteriorated today - now it says 'MAKEDEV: directory already
exists' (or something like that, serial console doesnt work for whatever reason)
and then hangs at the 'enabling hardware' (?) step. With selinux=0 it boots up
just fine, and i dont get the xDSL hang either.

Comment 3 Bill Nottingham 2005-05-05 15:36:39 UTC
Marking as a duplicate; this appears to be related to a udev bug.

*** This bug has been marked as a duplicate of 156862 ***


Note You need to log in before you can comment on or make changes to this bug.