Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156769 - gnome-sound-properties requires esd
Summary: gnome-sound-properties requires esd
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: David Lawrence
URL:
Whiteboard: bzcl34nup
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 05:41 UTC by Marius Andreiana
Modified: 2008-04-23 05:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-23 05:45:45 UTC


Attachments (Terms of Use)

Description Marius Andreiana 2005-05-04 05:41:36 UTC
With alsa 1.0.9 in development repository and dmix enabled by default, there's
no need to require esd. gstreamer uses alsa by default and it works.

GNOME sound preferences capplet doesn't allow events sounds without
checking Sound server checkbox, I assume only because the UI design. Please
remove this option and control-center's depency of libesd.so

Reference:
https://www.redhat.com/archives/fedora-devel-list/2005-April/msg00709.html
(note that issues 1 and 2 from that email are solved now)

Thanks

Comment 1 Bastien Nocera 2007-02-14 13:54:52 UTC
The playback code uses esd, so it needs to be running.

In F7, we should have pulse running, so the dependency wouldn't be on esound
anymore, but on Pulse directly.

Comment 2 Matthias Clasen 2007-02-14 19:23:24 UTC
the dependency is actually on /usr/bin/esd nowadays, which is provided by 
either esound or pulseaudio-esound-compat

Comment 3 Bug Zapper 2008-04-03 16:08:20 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 4 Matthias Clasen 2008-04-23 05:45:45 UTC
The dependency is gone nowadays


Note You need to log in before you can comment on or make changes to this bug.