Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156768 - GTKmm fails to install on normal OS install with anaconda. Thus programs that rely on it fail to load it in their proc address to display GTK+ through the GTKmm OO class inheritable library
Summary: GTKmm fails to install on normal OS install with anaconda. Thus programs that...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk+
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: David Lawrence
URL: none
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 05:19 UTC by Beer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-19 00:47:04 UTC


Attachments (Terms of Use)

Description Beer 2005-05-04 05:19:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
You must include GTKmm this time, we love GTK OO with class inheritance!!!
libstdc++ is included but no way to present a graphical interface with C++ OO, we need the GTKmm rpm on anaconda's package list.

The Program fails to load gtkmm so dependancy and fails. This is caused by the module loader searching the LD_LIBRARY_PATH directories for the libgtkmm.so file and not being able to find it, thus failing to load it in the proc address.

Version-Release number of selected component (if applicable):
gtkmm20-2.2.12-1

How reproducible:
Always

Steps to Reproduce:
1. Install FC
2. Use a program that depends on C++ GTK, aka gtkmm
3. See program not able to load dependant so module in proc address and die
  

Actual Results:  The Program fails to load gtkmm so dependancy and fails. This is caused by the module loader searching the LD_LIBRARY_PATH directories for the libgtkmm.so file and not being able to find it, thus failing to load it in the proc address.

Expected Results:  that anaconda installs gtkmm20 rpm on OS install and C++ programmers have a means to use GTKmm for OOriented graphical displays and class inheritance on GTK objects instead of passing a gobject pointer to every single function that performs actions on widgets.

Additional info:

not having GTKmm installed with FCore is annoying at best, and sucky at worst.

Comment 1 Jeremy Katz 2005-05-19 00:47:04 UTC
gtkmm is included in Fedora Extras


Note You need to log in before you can comment on or make changes to this bug.