Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156760 - Can't find ieee1394 and ohcil1394 module
Summary: Can't find ieee1394 and ohcil1394 module
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-04 01:09 UTC by Tung Ying Chang
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-03 22:14:02 UTC


Attachments (Terms of Use)

Description Tung Ying Chang 2005-05-04 01:09:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
Use OS default kernel of Redhat WS4 / WS4 U1 can't find ieee1394 and ohcil1394 module .

Version-Release number of selected component (if applicable):
kernel- 2.6.9 (Default kernel of Redhat WS4 and WS4 U1 Beta)

How reproducible:
Always

Steps to Reproduce:
1.Install Everything of Redhat WS4 / WS4 U1 then boot the system
2.Insert 1394 devices , can't find this devices in OS level
3.To check lsmod . don't find ieee1394 and ohcil1394
4.To try load ieee1394 and ohci1394 , can't load it because no those modules 
  

Additional info:

Comment 2 Steve Cleveland 2005-06-10 21:14:34 UTC
I second this.  In looking at the .config file in the kernel-devel package, it
appears that ieee1394 support isn't compiled into the kernel or built as a
module.  In WS3, it was part of the kernel-unsupported package, but I see no
such thing for WS4.

Comment 3 Aleksandar Milivojevic 2005-08-23 15:40:39 UTC
Yeah, would be nice-to-have feature (given there's more and more removable
storage device with firewire interface, and that camcorders are historically
firewire devices with USB models starting to appear only recently).

Until such a time...

I've just grabbed 2.6.9-16.EL SRPM from updatde 2 beta.  Seems some of the
IEEE1394 options are turned on, but not the "main switch" (CONFIG_IEEE1394). 
Don't know if device drivers would build without it.  However, you could always
recompile the SRPM and turn the option on.  Note that that would be your own
kernel, and you shouldn't bug Red Hat support too much if it starts crashing on
you (unless you can reproduce the crash with stock RHEL4 kernel).

Also, FC3 kernels might work too on RHEL4 (never attempted that, but it might work).

If you want to make your own spin of RHEL4 kernel with IEEE1394 support, grab
kernel SRPM package, install it, go to the sources directory:

$ for a in *.config; do \
  sed '/# CONFIG_IEEE1394 is not set/CONFIG_IEEE1394=m/g' $a > $a.new; \
  mv $a.new $a; \
  done
$ vi kernel-2.6.spec

Find line that begins with '%define release' and append some string to the end
of release number (to identify this is your own spin of the kernel).  For
example ".ieee1394".  This is so that your kernel packages do not clash with
original Red Hat kernel packages.

$ rpmbuild --target=i686 -ba kernel-2.6.spec

After it is done (will take a bit longer time to recompile all kernel packages),
you'll end up with kernel-2.6.9-xx.EL.ieee1394.i686.rpm and
kernel-2.6.9-xx.EL.ieee1394smp.i686.rpm (where xx is the release number of the
kernel, latest supported one is 11) that you can install.

Comment 4 Jason Baron 2005-11-03 22:14:02 UTC

*** This bug has been marked as a duplicate of 123044 ***

Comment 5 Steve Cleveland 2005-11-03 22:17:02 UTC
123044 is a restricted bug report.  Any way you could let us know the status?

Comment 6 Thomas J. Baker 2005-12-14 13:22:01 UTC
Yes, where are we supposed to get information about this if the main bug is
restricted?


Note You need to log in before you can comment on or make changes to this bug.