Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156750 - Linux crashes on shutdown
Summary: Linux crashes on shutdown
Keywords:
Status: CLOSED DUPLICATE of bug 155472
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-03 21:34 UTC by Nigel Horne
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-09 23:59:40 UTC


Attachments (Terms of Use)

Description Nigel Horne 2005-05-03 21:34:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050417 Fedora/1.7.7-1.3.1

Description of problem:
Sometimes, when shutting down this messages appears, followed by a crash:

kernel panic - not syncing: drivers/block/cfg-iosched.c 1065: spin_is_locked on uninitialized spinlock c48b841c (Not tainted)

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3

How reproducible:
Sometimes

Steps to Reproduce:
1. Shutdown the system
2.
3.
  

Actual Results:  kernel panic - not syncing: drivers/block/cfg-iosched.c 1065: spin_is_locked on uninitialized spinlock c48b841c (Not tainted)

Disc corruption then occurs with some loss of data (not much so far, but it's only a matter of time...)

Expected Results:  System should shut down properly.

Additional info:

Comment 1 Pete Zaitcev 2005-05-03 21:49:28 UTC
A picture of the actual screen might be helpful, I suspect.


Comment 2 Nigel Horne 2005-05-04 07:36:12 UTC
Please include instructions on how to do that. 

Comment 3 Dave Jones 2005-05-09 23:58:34 UTC
This sounds like another instance of the usb bug that was fixed recently.
The kernel in updates-testing should have this fixed.


Comment 4 Dave Jones 2005-05-09 23:59:40 UTC

*** This bug has been marked as a duplicate of 155472 ***


Note You need to log in before you can comment on or make changes to this bug.