Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156746 - Problems Compiling php-4.3.11-2.5.src.rpm
Summary: Problems Compiling php-4.3.11-2.5.src.rpm
Keywords:
Status: CLOSED DUPLICATE of bug 156745
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-03 20:50 UTC by Eli Wapniarski
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-03 22:09:02 UTC


Attachments (Terms of Use)

Description Eli Wapniarski 2005-05-03 20:50:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.0 (like Gecko)

Description of problem:
I tried to compile  php-4.3.11-2.5.src.rpm. I have installed compenants of   
net-snmp net-snmp-5.2.1-10.FC3. I have modified the SRPM so that I get all   
modules as shared compenants and seperate RPMS. I have been successfully   
doing this for two years.   
   
I received two errors during the testing phase which were fixed by the following   
modifications to the SPEC as indicated below. I do not believe that the solution is   
satisfactory as will be indicated by the output which is provided furthur below.   
   
# Tests that fail as of 4.3.11   
rm -f ext/standard/tests/array/bug31213.phpt \   
      ext/standard/tests/array/locale_sort.phpt \   
      ext/standard/tests/file/bug26938.phpt \   
      ext/standard/tests/file/proc_open01.phpt   
   
I first received the error concerning bug26938, applied the change as indicated   
above. Tried compiling again and received the second error concerning   
proc_open01. At which poing I added the modification as indicated.   
   
The output of the twp error messages during testing part of the compilation  
follows.   
   
=====================================================================  
FAILED TEST SUMMARY  
---------------------------------------------------------------------  
Bug #26938 (exec does not read consecutive long lines correctly) [ext/standard/t  
ests/file/bug26938.phpt]  
proc_open() regression test 1 (proc_open() leak) [ext/standard/tests/file/proc_o  
pen01.phpt]  
=====================================================================  
make: *** [test] Error 1  
+ set +x  
TEST FAILURE: ../ext/standard/tests/file/bug26938.diff --  
001- md5(line 0)= e86410fa2d6e2634fd8ac5f4b3afe7f3 (length 10)  
001+ PHP Warning:  Unknown(): Unable to load dynamic library  
'/usr/lib/php4/snmp  
.so' - /usr/lib/php4/snmp.so: undefined symbol: usmAES192PrivProtocol in  
Unknown  
 on line 0  
002- md5(line 1)= e84debf3a1d132871d7fe45c1c04c566 (length 20000)  
002+ md5(line 0)= e86410fa2d6e2634fd8ac5f4b3afe7f3 (length 10)  
003- md5(line 2)= c33b4d2f86908eea5d75ee5a61fd81f4 (length 10000)  
003+ md5(line 1)= e84debf3a1d132871d7fe45c1c04c566 (length 20000)  
004- md5(line 3)= 2ecdde3959051d913f61b14579ea136d (length 5)  
004+ md5(line 2)= c33b4d2f86908eea5d75ee5a61fd81f4 (length 10000)  
005- md5(line 4)= c33b4d2f86908eea5d75ee5a61fd81f4 (length 10000)  
005+ md5(line 3)= 2ecdde3959051d913f61b14579ea136d (length 5)  
006- md5(line 5)= 902fbdd2b1df0c4f70b4a5d23525e932 (length 3)  
006+ md5(line 4)= c33b4d2f86908eea5d75ee5a61fd81f4 (length 10000)  
007+ md5(line 5)= 902fbdd2b1df0c4f70b4a5d23525e932 (length 3)  
-- ../ext/standard/tests/file/bug26938.diff result ends.  
TEST FAILURE: ../ext/standard/tests/file/proc_open01.diff --  
003-   resource(%d) of type (stream)  
003+   resource(4) of type (stream)  
005-   resource(%d) of type (stream)  
005+   resource(5) of type (stream)  
007- string(5) "yay!  
007+ PHP Warning:  Unknown(): Unable to load dynamic library  
'/usr/lib/php4/snmp  
.so' - /usr/lib/php4/snmp.so: undefined symbol: usmAES192PrivProtocol in  
Unknown  
 on line 0  
008- "  
008+ string(5) "yay!  
009- array(3) {  
009+ "  
010-   [0]=>  
010+ array(3) {  
011-   int(1)  
011+   [0]=>  
012-   [1]=>  
012+   int(1)  
013-   int(2)  
013+   [1]=>  
014-   [2]=>  
014+   int(2)  
015-   int(3)  
015+   [2]=>  
016- }  
016+   int(3)  
017+ }  
-- ../ext/standard/tests/file/proc_open01.diff result ends.  
  
****************************************************************  
****************************************************************  
  
=====================================================================  
FAILED TEST SUMMARY  
---------------------------------------------------------------------  
proc_open() regression test 1 (proc_open() leak)  
[ext/standard/tests/file/proc_open01.phpt]  
=====================================================================  
make: *** [test] Error 1  
+ set +x  
TEST FAILURE: ../ext/standard/tests/file/proc_open01.diff --  
003-   resource(%d) of type (stream)  
003+   resource(4) of type (stream)  
005-   resource(%d) of type (stream)  
005+   resource(5) of type (stream)  
007- string(5) "yay!  
007+ PHP Warning:  Unknown(): Unable to load dynamic library  
'/usr/lib/php4/snmp.so' - /usr/lib/php4/snmp.so: undefined symbol:  
usmAES192PrivProtocol in Unknown on line 0  
008- "  
008+ string(5) "yay!  
009- array(3) {  
009+ "  
010-   [0]=>  
010+ array(3) {  
011-   int(1)  
011+   [0]=>  
012-   [1]=>  
012+   int(1)  
013-   int(2)  
013+   [1]=>  
014-   [2]=>  
014+   int(2)  
015-   int(3)  
015+   [2]=>  
016- }  
016+   int(3)  
017+ }  
-- ../ext/standard/tests/file/proc_open01.diff result ends.  
  

Version-Release number of selected component (if applicable):
php-4.3.11-2.5

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:

Comment 1 Joe Orton 2005-05-03 22:09:02 UTC

*** This bug has been marked as a duplicate of 156745 ***


Note You need to log in before you can comment on or make changes to this bug.