Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156740 - screen doesn't work correctly with iso-88591 charset in gnome-terminal: prints garbage for scandinavic characters
Summary: screen doesn't work correctly with iso-88591 charset in gnome-terminal: print...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: screen
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Petr Rockai
QA Contact: Brock Organ
URL:
Whiteboard:
: 156731 156733 156734 156735 156737 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-03 19:17 UTC by Toni Willberg
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-04 08:44:00 UTC


Attachments (Terms of Use)

Description Toni Willberg 2005-05-03 19:17:58 UTC
Description of problem:

inside screen user can't type åäöÃÃÃ, it prints garbage instead. This happens
with running screen in gnome-terminal with iso-8859-1 or -15 charset, but works
nicely with utf-8.

Version-Release number of selected component (if applicable):
 screen-4.0.2-8
 glibc-2.3.5-0.fc3.1
 ncurses-5.4-16


How reproducible:
 always

Steps to Reproduce:
 1. launch gnome-terminal, switch to iso-8859-1 or -15
 2. type åäöÃÃÃ
  
Actual results:
 ����

Expected results:
 åäöÃÃÃ

Additional info:
 IMO a blocker bug; renders screen unusable

Comment 1 Toni Willberg 2005-05-03 19:19:38 UTC
Typing åäöÃÃà _outside_ screen with same gnome-terminal (and it's settings
including charset) works nicely.

Please provide additional debugging information if required.



Comment 2 Toni Willberg 2005-05-03 19:22:18 UTC
*** Bug 156731 has been marked as a duplicate of this bug. ***

Comment 3 Toni Willberg 2005-05-03 19:23:55 UTC
*** Bug 156733 has been marked as a duplicate of this bug. ***

Comment 4 Toni Willberg 2005-05-03 19:25:27 UTC
*** Bug 156734 has been marked as a duplicate of this bug. ***

Comment 5 Toni Willberg 2005-05-03 19:27:25 UTC
*** Bug 156735 has been marked as a duplicate of this bug. ***

Comment 6 Toni Willberg 2005-05-03 19:31:02 UTC
*** Bug 156737 has been marked as a duplicate of this bug. ***

Comment 7 Toni Willberg 2005-05-03 19:35:06 UTC
(sorry for the dupes, Bugzilla has a bug that caused it to give internal server
error, and I didn't realize the inserted the bugs into the database anyway)

Comment 8 Petr Rockai 2005-05-04 07:36:27 UTC
Works for me in FC3. I suppose you set right encoding for screen, right? As    
in, if your gnome-terminal is iso-8859-1, you should run    
LC_ALL=en_US.iso-8859-1 screen (or analogous). The default settings is utf-8,   
so if you have utf-8 set up in locale and something else in gnome-terminal,   
it's pretty likely to break, yes (and that's actually not a bug IMO...).  And 
please next time be more careful with bugzilla, i received loads of mails 
about this... 

Comment 9 Toni Willberg 2005-05-04 08:44:00 UTC
(sorry about the mailflood again, I have notified the bugzilla admin about the bug)

It seems that I wasn't aware I should be setting LC_ALL manually, as it seems to
work without outside screen.

After setting LC_ALL=en_US.iso-8859-1 I get the characters correctly inside
screen too. There seems to be still some issues in Irssi, but that's
out-of-topic here. :)

So, I'll close this as NOTABUG as it was an illegal user error. ;)


Note You need to log in before you can comment on or make changes to this bug.