Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156722 - [RHEL3 U4] oops in pty_chars_in_buffer() calling thru NULL func ptr
Summary: [RHEL3 U4] oops in pty_chars_in_buffer() calling thru NULL func ptr
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Baron
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-03 17:25 UTC by Issue Tracker
Modified: 2013-03-06 05:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-13 02:36:53 UTC


Attachments (Terms of Use)

Description Issue Tracker 2005-05-03 17:25:11 UTC
Escalated to Bugzilla from IssueTracker

Comment 18 Jason Baron 2005-05-03 17:33:02 UTC
i posted an alternative implementation for this issue upstream. I'm tyring to
get it merged there. see:

http://marc.theaimsgroup.com/?l=linux-kernel&m=111342171410005&w=2

Comment 21 Jason Baron 2005-06-08 14:31:34 UTC
Sorry, i haven't posted a test kernel with my merged patch yet. I was trying to
re-create the original problem, and show that the patch fixed. I am yet unable
to do that. I can post my testing kernel here, if its really wanted, with the
caveat that engineering is still integrating and testing.

Comment 23 Jason Baron 2005-06-10 18:43:42 UTC
pointer to the kernel with the patch from comment #18 backported to rhel3, the
caveat from comment #21 sill applies. thanks.
http://people.redhat.com/~jbaron/2.4.21-32.6.EL.pty.1/ 

Comment 27 Jason Baron 2005-07-13 21:42:56 UTC
awaiting feedback on test kernel from comment #21, since customer claims to be
able to reproduce this frequently. thanks.

Comment 31 Jason Baron 2005-09-06 19:58:47 UTC
hmmm, any chance we are going to get feedback on this one?

Comment 32 Jason Baron 2005-09-12 19:48:08 UTC
anyways, i got the patch upstream, if this ifluences the customer at all, see:
http://marc.theaimsgroup.com/?l=git-commits-head&m=112630347529485&w=2

Comment 35 Ernie Petrides 2005-10-28 21:05:29 UTC
Just to clarify, we are waiting for feedback from the customer regarding
whether Jason's test kernel (indicated in comment #23 over 4 months ago)
resolves the problem.  I'm making the following comments public (as well
as the bug summary): 21, 23, 27, 31, 32.

Comment 36 Ernie Petrides 2005-12-13 02:36:53 UTC
Closing due to lack of response.


Note You need to log in before you can comment on or make changes to this bug.