Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156686 - Resolution 1280x800 not supported
Summary: Resolution 1280x800 not supported
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Søren Sandmann Pedersen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-03 12:09 UTC by Martin Welss
Modified: 2014-06-18 09:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-13 17:32:41 UTC


Attachments (Terms of Use)
generated xorg.conf (deleted)
2005-05-03 16:30 UTC, Martin Welss
no flags Details
xorg logfile from xorg-6.8.2-29 (deleted)
2005-05-04 12:06 UTC, Martin Welss
no flags Details
new generated xorg.conf (deleted)
2005-05-04 14:51 UTC, Martin Welss
no flags Details

Description Martin Welss 2005-05-03 12:09:05 UTC
Description of problem:
In the Resulotion Option Menu on Tab "Settings", 1280x800 is missing
(but the Monitor Option Menu on Tab "Hardware" supports it)
This is on a Laptop with Intel 855GM on chip graphics

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Søren Sandmann Pedersen 2005-05-03 15:06:32 UTC
Should be fixed in Rawhide. The packages you need to upgrade to check are "rhpl"
and "xorg-x11".

Please reopen if this is still a problem.


Comment 2 Martin Welss 2005-05-03 15:40:22 UTC
I updated the packages with "yum update rhpl xorg-x11".
Configuration now lets me select Resolution 1280x800, but after save and
restart, the resolution ist still at 1024x768
i810 Driver Problem?
 

Comment 3 Søren Sandmann Pedersen 2005-05-03 15:57:03 UTC
Can you attach (not inline) the generated xorg.conf file please.

(Also please make sure that you actually restarted the X server with
Ctrl-Alt-Del - logging out/logging in is not always enough).


Comment 4 Martin Welss 2005-05-03 16:30:38 UTC
Created attachment 113976 [details]
generated xorg.conf

Comment 5 Martin Welss 2005-05-03 16:32:26 UTC
Even after reboot, X comes up with 1024x768
see attached xorg.conf

Comment 6 Søren Sandmann Pedersen 2005-05-03 17:57:12 UTC
What exact release of X do get? Ie., what does "rpm -q xorg-x11" give you?


Comment 7 Martin Welss 2005-05-03 19:14:42 UTC
xorg-x11-6.8.2-27
I got it by doing "yum update" some hours ago.
 

Comment 8 Søren Sandmann Pedersen 2005-05-03 20:36:13 UTC
The latest version in rawhide is -29. The latest rhpl version is -161. These two
together should fix this problem. You can get them at 

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/

for example. I don't know if there is a yum command that will do it automatically.


Comment 9 Martin Welss 2005-05-04 12:06:41 UTC
Created attachment 114006 [details]
xorg logfile from xorg-6.8.2-29

please note the two lines "Not using Mode ..." 
the resolutions are definitvely supported, because Redmond XP can use them :-(
i810 Driver Problem? 

(II) I810(0): Monitor0: Using hsync range of 31.50-90.00 kHz
(II) I810(0): Monitor0: Using vrefresh value of 60.00 Hz
(II) I810(0): Not using mode "1280x800" (no mode of this name)
(II) I810(0): Not using mode "1152x864" (no mode of this name)
(--) I810(0): Virtual size is 1024x768 (pitch 1024)
(**) I810(0): *Built-in mode "1024x768"
(**) I810(0): *Built-in mode "800x600"
(**) I810(0): *Built-in mode "640x480"
(==) I810(0): DPI set to (75, 75)
(II) Loading sub module "fb"

Comment 10 Søren Sandmann Pedersen 2005-05-04 14:21:50 UTC
What does the generated xorg.conf file look like with the upgraded rhpl and the
upgraded server?


Comment 11 Martin Welss 2005-05-04 14:51:57 UTC
Created attachment 114013 [details]
new generated xorg.conf

Comment 12 Søren Sandmann Pedersen 2005-05-04 15:08:10 UTC
Could you check if the problem is fixed if you change the modeline from

   ModeLine "1280x800_60.00" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync

to

   ModeLine "1280x800" 83.5 1280 1344 1480 1680 800 801 804 828 -hsync +vsync

Ie. delete "_60.00" from the name.


Comment 13 Martin Welss 2005-05-04 15:24:26 UTC
no difference (after reboot)


Comment 14 Martin Welss 2005-05-13 12:53:44 UTC
it works now:
- the real resolution is 1280x768 not 800 (my fault)
- I must use the tool "855resolution" by Alain Poirier to patch the buggy bios
to allow this resolution (http://perso.wanadoo.fr/apoirier/)


Comment 15 Søren Sandmann Pedersen 2005-05-13 17:32:41 UTC
In that case, I'll close this bug as RAWHIDE.



Note You need to log in before you can comment on or make changes to this bug.