Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156681 - via s3 unichrome graphics not recognized
Summary: via s3 unichrome graphics not recognized
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-03 11:36 UTC by Avi Kivity
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: xorg-x11-drv-via-0.1.33.2-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-03-22 10:22:09 UTC


Attachments (Terms of Use)

Description Avi Kivity 2005-05-03 11:36:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
my integrated graphics adapter is not recognized.

lspci output:

01:00.0 Class 0300: 1106:3108 (rev 01)
        Subsystem: 1458:d000
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32
        Interrupt: pin ? routed to IRQ 16
        Region 0: Memory at e4000000 (32-bit, prefetchable) [size=64M]
        Region 1: Memory at e8000000 (32-bit, non-prefetchable) [size=16M]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [70] AGP version 3.0
                Status: RQ=256 Iso- ArqSz=0 Cal=7 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3+ Rate=x4,x8
                Command: RQ=1 ArqSz=0 Cal=0 SBA+ AGP- GART64- 64bit- FW- Rate=<none>

on fc4t2, system-config-display detected the vesa driver. with 1.0.27-1, I get a traceback
[root@blast ~]# system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 396, in ?
    if xconfigpath and not output_file_specified:
NameError: name 'xconfigpath' is not defined

due to vc.videocards being an empty list.

Version-Release number of selected component (if applicable):
system-config-display-1.0.27-1

How reproducible:
Always

Steps to Reproduce:
1. system-config-display on my machine.
  

Actual Results:  (fc4t2) vesa driver selected
(devel) crash

Expected Results:  non-vesa graphics

Additional info:

Comment 1 Jonathan Kamens 2005-08-09 09:59:25 UTC
There are free unichrome drivers.  See unichrome.sourceforge.net.  It's not
clear to me why they haven't been incorporated into the official x.org
distribution.  Perhaps Red Hat could add them as a patch?  That would be a huge
help since it would save all us poor unichrome owners from having to compile the
entire x.org distribution!


Comment 2 Avi Kivity 2006-03-22 10:22:09 UTC
FC5 x.org includes the via driver. 


Note You need to log in before you can comment on or make changes to this bug.