Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156675 - broken pear Cannot instantiate non-existent class: pear_command_auth-init
Summary: broken pear Cannot instantiate non-existent class: pear_command_auth-init
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: php
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
: 156676 172747 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-03 06:58 UTC by toggg
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-03 08:30:06 UTC


Attachments (Terms of Use)

Description toggg 2005-05-03 06:58:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
Just upgrated a basic FC3.
The shipped pear is broken.
# pear -V
PHP Fatal error:  Cannot instantiate non-existent class:  pear_command_auth-init in /usr/share/pear/PEAR/Command.php on line 271

Checking files CVS Id it appears that it's an unstable 1.3.6

Version-Release number of selected component (if applicable):
php-pear-4.3.11-2.5

How reproducible:
Always

Steps to Reproduce:
1.pear -V
2.
3.
  

Actual Results:  PHP Fatal error:  Cannot instantiate non-existent class:  pear_command_auth-init in /usr/share/pear/PEAR/Command.php on line 271


Expected Results:  Showing versions number

Additional info:

Comment 1 Joe Orton 2005-05-03 07:19:54 UTC
I can't reproduce this.

# pear -V
PEAR Version: 1.3.5
PHP Version: 4.3.11
Zend Engine Version: 1.3.0
...

Can you verify that the PEAR installation is not modified?

What's the output of:

# rpm -V php-pear php



Comment 2 Joe Orton 2005-05-03 07:27:44 UTC
*** Bug 156676 has been marked as a duplicate of this bug. ***

Comment 3 toggg 2005-05-03 07:33:10 UTC
rpm -V php-pear php

gives no output...

from rpm, file PEAR/Command.php:

/ $Id: Command.php,v 1.16.4.13 2005/03/28 16:56:58 cellog Exp $

This version is not issued from cvs.php.net ?




Comment 4 toggg 2005-05-03 08:14:38 UTC
I'm terribly confused..
It's a mix with pear-1.4.0a12 from cvs which was previously installed.
Indeed command.php from fc3 scans the Command subfolder and founded some extra
file added by the new version from pear: PEAR/Command/Auth-init.php which
appears to be incompatible ... (this file was added on Mar 24 2005)
But why would this subfolder not cleaned first ?
If I remove all the files from it and force install again, I obtain:
# pear -V
PEAR Version: 1.3.5
PHP Version: 4.3.11
Zend Engine Version: 1.3.0
Running on: Linux ancilla.toggg.net 2.6.11-1.14_FC3smp #1 SMP Thu Apr 7 19:38:19
EDT 2005 i686

I will report this downgrade incompatibility to pear's devs...
So, sorry again !



Comment 5 Joe Orton 2005-05-03 08:30:06 UTC
Thanks for tracking the issue down.

Comment 6 Clif 2005-06-26 22:07:43 UTC
(In reply to comment #4)
> I'm terribly confused..
> It's a mix with pear-1.4.0a12 from cvs which was previously installed.
> Indeed command.php from fc3 scans the Command subfolder and founded some extra
> file added by the new version from pear: PEAR/Command/Auth-init.php which
> appears to be incompatible ... (this file was added on Mar 24 2005)
> But why would this subfolder not cleaned first ?
> If I remove all the files from it and force install again, I obtain:
> # pear -V
> PEAR Version: 1.3.5
> PHP Version: 4.3.11
> Zend Engine Version: 1.3.0
> Running on: Linux ancilla.toggg.net 2.6.11-1.14_FC3smp #1 SMP Thu Apr 7 19:38:19
> EDT 2005 i686
> 
> I will report this downgrade incompatibility to pear's devs...
> So, sorry again !
> 
> 

I'm experienceing the same issues.  If I remove all files under
/usr/share/pear/PEAR/Command/, then I can't install/update/etc. via pear:
# pear -V
PEAR Version: 1.1
PHP Version: 4.3.2
Zend Engine Version: 1.3.0

# pear install DB
No such command

Comment 7 Joe Orton 2005-06-27 06:31:16 UTC
Clif, run "rpm --erase php-pear" then "yum install php-pear" to re-install the
pear module.  Please use fedora-list@redhat.com or http://fedoraforum.org/ for
support questions, not bugzilla.

Comment 8 Joe Stump 2005-07-11 18:17:31 UTC
I've posted a fix for this into the PEAR bug entry for this problem. It's an extremely simple fix:

http://pear.php.net/bugs/bug.php?id=4740

--Joe

Comment 9 Joe Orton 2005-11-09 07:21:53 UTC
*** Bug 172747 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.