Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156673 - the command /sbin/resize2fs is missing on zSeries
Summary: the command /sbin/resize2fs is missing on zSeries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: e2fsprogs
Version: 4.0
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Thomas Woerner
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-03 06:28 UTC by Falko Pilz
Modified: 2015-01-08 00:09 UTC (History)
3 users (show)

Fixed In Version: 1.35-12.1.EL4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-11 16:29:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Falko Pilz 2005-05-03 06:28:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
it's nice that ext2online was added, but this tool could only enlarge mounted filesystem.
What about shrinking one?
resize2fs which is in the fedora versions of e2fstools*.rpm isn't in the EL rpms, but in the tool called ext2resize which meen to replace resize2fs (or be a rename) isn't also not in the both installed packages(s390 or s390x).

Version-Release number of selected component (if applicable):
e2fstools-1.35-7.1

How reproducible:
Always

Steps to Reproduce:
no one, because missing command

Additional info:

Comment 1 Stephen Tweedie 2005-05-03 13:26:12 UTC
resize2fs was disabled for the initial RHEL-4 GA release because of last-minute
conflicts found with online resize.  Those have been fixed and resize2fs will be
reenabled in RHEL-4 U1.

Comment 2 Alin Osan 2005-05-24 20:29:20 UTC
(In reply to comment #1)
> resize2fs was disabled for the initial RHEL-4 GA release because of last-minute
> conflicts found with online resize.  Those have been fixed and resize2fs will be
> reenabled in RHEL-4 U1.

resize2fs is still missing. AKAIK, right now there is no tool to shrink a fs on
RHEL 4.
 

Comment 3 Stephen Tweedie 2005-05-24 21:12:10 UTC
Correct; it will be reenabled in RHEL-4 U1, in package versions
e2fsprogs-1.35-12.1.EL4 or later.

Comment 4 richard lee 2006-04-11 14:01:53 UTC
when does RHEL-4 U1 get released?

Comment 5 Jay Turner 2006-04-11 16:29:39 UTC
U1 went out months and months ago.  U3 is now available via RHN so you should be
able to grab that and get the fix to the reported issue.


Note You need to log in before you can comment on or make changes to this bug.