Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156659 - mount does not autosense cramfs image
Summary: mount does not autosense cramfs image
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: e2fsprogs
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-02 22:51 UTC by Mike McLean
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 1.37-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-01 12:53:57 UTC


Attachments (Terms of Use)
libblkid cramfs bugfix (deleted)
2005-05-03 12:37 UTC, Karel Zak
no flags Details | Diff

Description Mike McLean 2005-05-02 22:51:47 UTC
* util-linux-2.12p-8
* glibc-2.3.5-4
* kernel-2.6.11-1.1276_FC4

Take a cramfs image (like stage2.img from the install disc) and try to 
mount it with mount -o loop.  Mount fails to autosense the fstype and the mount
fails.  If -t cramfs is added to the command line, the mount succeeds.

Furthermore, when the mount -o loop fails, the loop device is not freed. So
after running this command a few times you find yourself completely out of loop
devices.

Comment 2 Karel Zak 2005-05-03 12:37:41 UTC
Created attachment 113959 [details]
libblkid cramfs bugfix

The problem is with the libblkid (from e2fsprogs package). There's wrong cramfs
magic number. The patch contains:

- fix of cramfs magic number
- support for cramfs LABELs

I sent it to e2fsprogs upstream too.

Comment 4 Karel Zak 2005-09-01 12:53:57 UTC
Fixed in FC4|5. The problem is unimportant for RHEL3|4 where is the mount
command without libblkid. Closing...


Note You need to log in before you can comment on or make changes to this bug.