Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156656 - FC3->FC4 x86_64 Upgrade, bash segfaults
Summary: FC3->FC4 x86_64 Upgrade, bash segfaults
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
: 156657 (view as bug list)
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-05-02 22:18 UTC by Warren Togami
Modified: 2017-01-10 12:21 UTC (History)
1 user (show)

Fixed In Version: 2.3.5-6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-05 11:53:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1404435 None None None Never

Internal Links: 1404435

Description Warren Togami 2005-05-02 22:18:03 UTC
Description of problem:
FC3 x86_64 clean "Workstation" install with 32bit Compat added (244 packages). 
Upgrade to FC4-re0429.0.  Resulting system is extremely hosed.

http://people.redhat.com/wtogami/temp/chroot-x86-64-segfault.txt
bash segfaults due to weird mix of FC3 and FC4 after "upgrade"  System itself
isn't bootable but segfault happens when I attempt to chroot into /mnt/sysimage
in rescue mode.

Comment 1 Warren Togami 2005-05-02 22:31:09 UTC
http://people.redhat.com/wtogami/temp/packagelist-fc3-fc4-x86-64-upgrade.txt
Packages rpmdb thinks are installed after this anaconda upgrade attempt.

Comment 2 Jeremy Katz 2005-05-03 02:02:23 UTC
This is caused by glibc_post_upgrade not removing /lib64/tls/*

Comment 3 Jeremy Katz 2005-05-03 02:02:54 UTC
*** Bug 156657 has been marked as a duplicate of this bug. ***

Comment 4 Jakub Jelinek 2005-05-05 11:53:13 UTC
Should be fixed in glibc-2.3.5-6.


Note You need to log in before you can comment on or make changes to this bug.