Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156633 - gnome-panel crashes upon opening documents
Summary: gnome-panel crashes upon opening documents
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-02 18:53 UTC by Konstantin Ryabitsev
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: gnome-panel-2.10.1-9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-04 15:08:56 UTC


Attachments (Terms of Use)

Description Konstantin Ryabitsev 2005-05-02 18:53:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
This usually occurs when opening new applications, and not every time, so it's a bit of a heisenbug. However, I was finally able to catch the crash in a strace, so hopefully that will help someone to track down what is causing the segfault.

This machine: current devel (as of May 2, 2005), AMD 1600+, 1GB memory, NIS, NFS-mounted homedir (via autofs), with selinux in targeted mode.

Version-Release number of selected component (if applicable):
gnome-panel-0:2.10.1-7.i386

How reproducible:
Sometimes

Steps to Reproduce:
1. Open a few applications. Used to happen consistently while opening archives from Firefox using file-roller, until I tried to strace that, at which point it stopped being reproducible.



Actual Results:  From time to time pops up a gnome segfault window with "The application gnome-panel crashed." No apparent consistency, at least from usage pattern.

Additional info:

http://phy.duke.edu/~icon/misc/panel.strace.gz

Comment 1 Jeremy Katz 2005-05-02 18:57:32 UTC
When the gnome-segfault thing pops up, can you get a backtrace with it?   That's
going to be more useful in tracking down exactly where it's coming from.

Comment 2 Mark McLoughlin 2005-05-02 18:59:16 UTC
For more information on obtaining stack traces:

  http://fedoraproject.org/wiki/StackTraces

Also, if you install gnome-panel-debuginfo and libwnck-debuginfo, that should
help get a better stack trace.

Comment 3 Konstantin Ryabitsev 2005-05-02 21:04:17 UTC
Backtrace was generated from '/usr/bin/gnome-panel'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208768832 (LWP 10065)]
[New Thread -1211565136 (LWP 10074)]
0x00dc5402 in ?? ()
#0  0x00dc5402 in ?? ()
#1  0x005f3fdb in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x02b5c080 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x080a0509 in egg_recent_model_changed (model=0x8ba68d8)
    at egg-recent-model.c:1671
#5  0x080a0584 in egg_recent_model_changed_timeout (model=0x616d7869)
    at egg-recent-model.c:646
#6  0x00457f06 in g_main_context_wakeup () from /usr/lib/libglib-2.0.so.0
#7  0x004563ee in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#8  0x004593f6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#9  0x004596e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#10 0x008481b5 in IA__gtk_main () at gtkmain.c:963
#11 0x08064257 in main (argc=134874483, argv=0x80a0573) at main.c:90

Thread 2 (Thread -1211565136 (LWP 10074)):
#0  0x00dc5402 in ?? ()
No symbol table info available.
#1  0x00389a93 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x00459248 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x004596e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x0023c3be in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x00471e9a in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x005eeb80 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x003939ce in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread -1208768832 (LWP 10065)):
#0  0x00dc5402 in ?? ()
No symbol table info available.
#1  0x005f3fdb in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x02b5c080 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x080a0509 in egg_recent_model_changed (model=0x8ba68d8)
    at egg-recent-model.c:1671
	list = (GList *) 0x0
#5  0x080a0584 in egg_recent_model_changed_timeout (model=0x616d7869)
    at egg-recent-model.c:646
No locals.
#6  0x00457f06 in g_main_context_wakeup () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#7  0x004563ee in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x004593f6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#9  0x004596e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#10 0x008481b5 in IA__gtk_main () at gtkmain.c:963
	tmp_list = (GList *) 0x80a2df0
	functions = (GList *) 0x0
	init = (GtkInitFunction *) 0x2c5ca0
	loop = (GMainLoop *) 0x8b6d8e0
#11 0x08064257 in main (argc=134874483, argv=0x80a0573) at main.c:90
No locals.

----

If I need to load any more debuginfo files, let me know: I seem to have gotten
to the point where I see it happen quite often.

Comment 4 Mark McLoughlin 2005-05-03 06:51:13 UTC
Looks like it might be this:

  http://bugzilla.gnome.org/show_bug.cgi?id=170660

Could you attach the contents of your ~/.recently-used ?

Comment 5 Konstantin Ryabitsev 2005-05-03 14:42:29 UTC
Hmm... well, I can, but only if I mangle the filenames: it's a 100Kb file that
goes back several months. I kinda like my privacy. Will it still be useful with
mangled filenames?

I have moved it out of the way, so I'll see how the panel acts today, with no
.recently-used stuff in place.

Comment 6 Mark McLoughlin 2005-05-03 14:59:59 UTC
If you don't get any crashes with a fresh ~/.recently-used file, maybe just try
and narrow it down to the entry that's causing the crash?

If it still happens with a fresh ~/.recently-used, just re-open

Comment 7 Konstantin Ryabitsev 2005-05-03 21:15:12 UTC
Yep, just got a crash. Here's the .recently-used:

<?xml version="1.0"?>
<RecentFiles>
  <RecentItem>
    <URI>file:///tmp/verbiste-0.1.10-4.failure.log</URI>
    <Mime-Type>text/x-log</Mime-Type>
    <Timestamp>1115154792</Timestamp>
    <Groups>
      <Group>gedit</Group>
    </Groups>
  </RecentItem>
  <RecentItem>
    <URI>file:///home/einstein/staff/icon/public/work/index.html</URI>
    <Mime-Type>text/html</Mime-Type>
    <Timestamp>1115143602</Timestamp>
    <Groups>
    </Groups>
  </RecentItem>
  <RecentItem>
    <URI>file:///home/einstein/staff/icon/am%C3%A9lie.txt</URI>
    <Mime-Type>text/plain</Mime-Type>
    <Timestamp>1115143323</Timestamp>
    <Groups>
      <Group>gedit</Group>
    </Groups>
  </RecentItem>
</RecentFiles>


I think it crashes right after writing the .recently-used file, since it crashed
while I was opening verbiste-0.1.10-4.failure.log.

Comment 8 Mark McLoughlin 2005-05-04 15:08:56 UTC
Okay, thanks. I found a pretty pathological reproducer and think I tracked it
down from that.

Re-open if 2.10.1-9 still crashes the same way.

* Wed May  4 2005 Mark McLoughlin <markmc@redhat.com> 2.10.1-9
- Fix crash with "Recent Documents" menu (bug #156633)



Note You need to log in before you can comment on or make changes to this bug.