Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156631 - up2date perl fails with conflicts
Summary: up2date perl fails with conflicts
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-02 18:38 UTC by jørgen nørgaard
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-06 09:45:30 UTC


Attachments (Terms of Use)

Description jørgen nørgaard 2005-05-02 18:38:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050427 Camino/0.8.4

Description of problem:
Running up2date detects new perl rpm, but installing it fails.

Perl installation has only been manipulated with the installer and possibly up2date.


up2date perl
http://fedora.redhat.com/download/up2date-mirrors/fedora-core-3
using mirror: http://www.las.ic.unicamp.br/pub/fedora/linux/core/3/x86_64/os/
http://fedora.redhat.com/download/up2date-mirrors/updates-released-fc3
using mirror: http://mirrors.kernel.org/fedora/core/updates/3/x86_64/

Fetching Obsoletes list for channel: fedora-core-3...

Fetching Obsoletes list for channel: updates-released-fc3...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
perl                                    5.8.5          12.FC3            x86_64


Testing package set / solving RPM inter-dependencies...
########################################
RPM package conflict error.  The message was:
Test install failed because of package conflicts:
file /usr/lib/perl5/5.8.5/File/Path.pm from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/c2ph.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/cpan.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/dprofpp.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/enc2xs.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/find2perl.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/h2ph.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/h2xs.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/libnetcfg.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/perlbug.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/perlcc.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/perlivp.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/piconv.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/pl2pm.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/pod2html.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/pod2latex.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/pod2man.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/pod2text.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/pod2usage.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/podchecker.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/podselect.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/prove.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/psed.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/pstruct.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/s2p.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/splain.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9
file /usr/share/man/man1/xsubpp.1.gz from install of perl-5.8.5-12.FC3 conflicts with file from package perl-5.8.5-9



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run up2date

(It is enough for me atleast)


  

Additional info:

Comment 1 Nalin Dahyabhai 2005-05-04 17:36:22 UTC
This isn't an up2date bug, per:
https://www.redhat.com/archives/fedora-devel-list/2005-May/msg00047.html

Comment 2 jørgen nørgaard 2005-05-06 09:43:56 UTC
On x86_64 perl-5.8.5 is twice


A work-around is to remove perl from the rpm database and then run up2date.

(like: rpm --justdb --nodeps --allmatches -e perl-5.8.5)

This is non-destructive in the way that installed files are not touched. The rpm database appears to be 
correct after up2date

Aterwards "yum list perl" indicates that only x86_64 is installed.



Comment 3 jørgen nørgaard 2005-05-06 09:45:30 UTC
Obviously not a bug in up2date.




Note You need to log in before you can comment on or make changes to this bug.