Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156630 - oocalc can't export to CSV
Summary: oocalc can't export to CSV
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-02 18:34 UTC by Bill Nottingham
Modified: 2014-03-17 02:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-03 07:22:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 46800 None None None Never

Description Bill Nottingham 2005-05-02 18:34:16 UTC
Description of problem:

SSIA

Version-Release number of selected component (if applicable):

1.9.93-1

How reproducible:

Every time

Steps to Reproduce:
1. open a .xls file
2. try to get .csv out
  
Actual results:

@$&&$!&

There is:

a) Export
b) Export to PDF

both of which do the same thing. Perhaps one should be removed/renamed.

There is also "Save As", which, according to the help, is supposed to have
a file type selector. But there is no selector there.

Comment 1 Bill Nottingham 2005-05-02 18:39:52 UTC
A-ha. If I click on the 'Browse for other folders' tick, the format selector is
in that expander.

I'm guessing that's not what's intended.

Comment 2 Caolan McNamara 2005-05-03 07:22:59 UTC
Basically the stock gtk file-chooser is not a great file dialog for anything
with a degree of complexity. For 2.0.1 I'm going to make it like the gimp-2.2
dialog with a seperation of the "filtering" on a suffix/mime-type and the actual
"format" in a seperate list. 


Note You need to log in before you can comment on or make changes to this bug.