Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156629 - ypbind quits silently after kernel update
Summary: ypbind quits silently after kernel update
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ypserv
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-02 18:30 UTC by Clinton
Modified: 2015-01-08 00:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-19 19:03:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Clinton 2005-05-02 18:30:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
After updating Enterprise AS 3 kernel to 2.4.21-27.0.4.El.smp, NIS and CVS no longer function

Version-Release number of selected component (if applicable):
ypbind-1.12-5.21.1; kernel-2.4.21-27.0.4.EL.smp

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.service ypbind restart
2.
3.
  

Actual Results:  Shutting down NIS services:                                [  OK  ]
Binding to the NIS domain: [ OK ]
Listening for an NIS domain server.

Expected Results:  Shutting down NIS services:                                [  OK  ]
Binding to the NIS domain: [ OK ]
Listening for an NIS domain server.
Found server <NIS server name>

Additional info:

Trying to login to an NIS account from the client shows the following in the
server's /var/log/messages (server is "skippy", NIS domainname is "dippy"):

---------------------
Apr 27 09:56:17 skippy ypserv[2348]: refused connect from 192.168.168.61:955 to
procedure ypproc_match (dippy,passwd.byname;0)
Apr 27 09:56:21 skippy ypserv[2348]: refused connect from 127.0.0.1:808 to
procedure ypproc_domain (dippy,;0)
---------------------

'ypcat passwd' from the client gives the following:

---------------------
No such map passwd.byname. Reason: No such map in server's domain
---------------------

I think that the client isn't actually binding to the NIS domain server.
I am not certain whether a message reporting a successful bind is supposed to be output.

When I try to login to CVS I get the following:
----------
cvs [login aborted]: connect to skippy(127.0.0.1):2401 failed: Connection refused
----------

This bug is similar to 155967, but I believe different enough to warrant it's own report.

Comment 1 RHEL Product and Program Management 2007-10-19 19:03:15 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.