Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156620 - Permissions are incorrect on /etc/ntp
Summary: Permissions are incorrect on /etc/ntp
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ntp
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Raszyk
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-02 15:59 UTC by Joshua Weage
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-24 08:17:10 UTC


Attachments (Terms of Use)

Description Joshua Weage 2005-05-02 15:59:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
ntpd produces the following error in /var/log/messages:

can't open /etc/ntp/drift.TEMP: Permission denied

The default /etc/sysconfig/ntpd config runs ntpd as the ntp user, which is fine.  However, the ntpd user cannot write to /etc/ntp by default, so ntpd is unable to create the drift file.

The solution is to change the permissions on /etc/ntp to ntp:root and chmod 775.

Version-Release number of selected component (if applicable):
4.1.2-4

How reproducible:
Always

Steps to Reproduce:
1.  Enable ntpd
2.  See error about drift.TEMP in syslog
3.
  

Expected Results:  No error messages.

Additional info:

Comment 1 Torkil Zachariassen 2005-10-19 15:39:28 UTC
The manual says the drift file should be in /var/lib/ntp, which is owned by
ntp.ntp mode 755.

Perhaps a line like
  driftfile /var/lib/ntp/drift
is required in
  /etc/ntp.conf



Comment 2 Petr Raszyk 2005-10-24 08:17:10 UTC
To comment #1

Thanks .
ntp.conf:
#
# Drift file.  Put this in a directory which the daemon can write to.
# No symbolic links allowed, either, since the daemon updates the file
# by creating a temporary in the same directory and then rename()'ing
# it to the file.
#
driftfile /var/lib/ntp/drift
broadcastdelay  0.008





Note You need to log in before you can comment on or make changes to this bug.