Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156604 - Evolution crashes if cancelling a folder renaming
Summary: Evolution crashes if cancelling a folder renaming
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-02 13:02 UTC by Joachim Backes
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: evolution-2.8.2.1-2.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-01 03:05:13 UTC


Attachments (Terms of Use)

Description Joachim Backes 2005-05-02 13:02:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
Try to rename a evolution folder, and if the popup appears for the new folder name, the cancel this operation. Evolution will immediately die.

Version-Release number of selected component (if applicable):
evolution-2.0.4-4

How reproducible:
Always

Steps to Reproduce:
1.Clicking a folder with right mouse button
2.Say: Rename
3.Cancel the rename
  

Actual Results:  Evol crashes

Expected Results:  dismiss the rename window

Additional info:

none

Comment 1 Dave Malcolm 2005-05-02 18:40:27 UTC
Thanks for the bug report. Without a stack trace from the crash it is very hard
to determine what caused the crash. Please see
http://fedoraproject.org/wiki/StackTraces 
for more information about getting a useful stack trace.

Comment 2 Joachim Backes 2005-05-03 04:50:58 UTC
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1228744480 (LWP 26163)]
0xb725d603 in strchr () from /lib/tls/libc.so.6
(gdb) where
#0  0xb725d603 in strchr () from /lib/tls/libc.so.6
#1  0xb6b37357 in em_folder_tree_create_folder ()
   from /usr/lib/evolution/2.0/components/libevolution-mail.so
#2  0xb73c33ae in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#3  0xb73ab347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#4  0xb73c1ae1 in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#5  0xb73c2cbc in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#6  0xb73c2f5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#7  0xb77fc149 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#8  0xb7717bd0 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#9  0xb7717eda in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#10 0xb770e5eb in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
#11 0xb7708677 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#12 0xb73ab6b2 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#13 0xb73ab347 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#14 0xb73c1646 in g_signal_has_handler_pending ()
   from /usr/lib/libgobject-2.0.so.0
#15 0xb73c2913 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#16 0xb73c2f5a in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#17 0xb77fc2d5 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#18 0xb770693b in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#19 0xb7706c40 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#20 0xb74b40c2 in gdk_event_get_graphics_expose ()
   from /usr/lib/libgdk-x11-2.0.so.0
#21 0xb73437bb in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#22 0xb7345242 in g_main_context_acquire () from /usr/lib/libglib-2.0.so.0
#23 0xb73454ef in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#24 0xb7a94dd5 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#25 0x08063b09 in main ()
(gdb)


Comment 3 Dave Malcolm 2005-05-12 20:05:27 UTC
Thanks.

Please can you install the evolution-debuginfo package and generate a new stack
strace.  See http://fedoraproject.org/wiki/StackTraces 
for more information.

It looks like this might be a general upstream Evolution problem; it may be
worth filing it upstream here:
http://bugzilla.gnome.org
as more people who know the code will be looking at the bug report there.

Comment 5 Matthew Barnes 2007-01-01 03:05:13 UTC
Unable to reproduce this problem in Fedora Core 6.

Comment 6 Joachim Backes 2007-01-05 11:05:38 UTC
Call may be closed. Cannot reproduce it in my running FC6.


Note You need to log in before you can comment on or make changes to this bug.