Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156596 - MakeMaker sometimes builds invalid Makefiles
Summary: MakeMaker sometimes builds invalid Makefiles
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: perl
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-02 10:52 UTC by Landon Curt Noll
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-08 23:07:21 UTC


Attachments (Terms of Use)

Description Landon Curt Noll 2005-05-02 10:52:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
The ExtUtils::MakeMaker as found in RHEL3's perl-5.8.0-89.10 fails
to form a valid Makefile for Digest::MD5 version 2.33.


Version-Release number of selected component (if applicable):
perl-5.8.0-89.10

How reproducible:
Always

Steps to Reproduce:
1. perl -MCPAN -e 'install Digest::MD5;'
2.
3.
  

Actual Results:  CPAN: Storable loaded ok
Going to read /usr/local/src/cpan/Metadata
  Database was generated on Sun, 01 May 2005 19:03:17 GMT
Running install for module Digest::MD5
Running make for G/GA/GAAS/Digest-MD5-2.33.tar.gz
CPAN: Digest::MD5 loaded ok
CPAN: Compress::Zlib loaded ok
Checksum for /usr/local/src/cpan/sources/authors/id/G/GA/GAAS/Digest-MD5-2.33.tar.gz ok
Scanning cache /usr/local/src/cpan/build for sizes
Digest-MD5-2.33/
Digest-MD5-2.33/t/
Digest-MD5-2.33/t/md5-aaa.t
Digest-MD5-2.33/t/clone.t
Digest-MD5-2.33/t/badfile.t
Digest-MD5-2.33/t/utf8.t
Digest-MD5-2.33/t/bits.t
Digest-MD5-2.33/t/align.t
Digest-MD5-2.33/t/files.t
Digest-MD5-2.33/README
Digest-MD5-2.33/MANIFEST
Digest-MD5-2.33/hints/
Digest-MD5-2.33/hints/MacOS.pl
Digest-MD5-2.33/hints/irix_6.pl
Digest-MD5-2.33/hints/dec_osf.pl
Digest-MD5-2.33/Changes
Digest-MD5-2.33/Makefile.PL
Digest-MD5-2.33/MD5.xs
Digest-MD5-2.33/typemap
Digest-MD5-2.33/MD5.pm
Digest-MD5-2.33/rfc1321.txt
Removing previously used /usr/local/src/cpan/build/Digest-MD5-2.33

  CPAN.pm: Going to build G/GA/GAAS/Digest-MD5-2.33.tar.gz

Perl's config says that U32 access must be aligned.
Checking if your kit is complete...
Looks good
Writing Makefile for Digest::MD5
Makefile:85: *** missing separator.  Stop.
  /usr/bin/make  -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible


Expected Results:  A valid Makefile for Digest::MD5 version 2.33 is formed and the Perl module builds.

Additional info:

A quick glance at the Makefile produced by MakeMaker shows that it is invalid.
For example:

# cd /usr/local/cpan/build/Digest-MD5-2.33
# perl Makefile.PL
Perl's config says that U32 access must be aligned.
Writing Makefile for Digest::MD5
# make
Makefile:85: *** missing separator.  Stop.

Looking at the Makefile starting at line 75, we see malformed Make lines:

installvendorhtml3=''
installvendorlib='/usr/lib/perl5/vendor_perl/5.8.
INSTALLVENDORLIB = ib/perl5'
installusrbinperl='def
INSTALLARCHLIB = /usr/lib/perl5/5.8.0/i386-linux-thread-multi
INSTALLSITEARCH = /usr/lib/
INSTALLVENDORARCH = /usr/
INSTALLBIN = /usr/bin'
installhtml1dir=''
installhtml3dir=''
installman1
INSTALLSITEBIN = /usr
INSTALLVENDORBIN = /usr/bin'
installvendorhtml1=''
installvendorhtml3=''
installvendorlib='/u
INSTALLSCRIPT = /usr/bin
PERL_LIB = /usr/lib/perl5/5.8.0
PERL_ARCHLIB = /usr/lib/perl5/5.8.0/i386-linux-thread-multi
SITELIBEXP = '/usr/lib/perl5/site_perl'
sit
SITEARCHEXP = /usr/lib/pe
LIBPERL_A = libperl.a'
libc='
FIRST_MAKEFILE = Makefile
MAKE_APERL_FILE = Makefile.aperl
PERLMAINCC = $(CC)
PERL_INC = /usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE
PERL = /usr/bin/perl

NOTE: RHEL3 is shipping with MakeMaker version 6.03.  It appears that
      version 6.12 can correctly build the Makefile under OS X.  So I
      suspect there is an issue with the older RHEL3 MakeMaker.

Please consider sending out a new RHEL3 perl RPM with a more up to date
ExtUtils::MakeMaker so that we can build CPAN modules.

Comment 1 Jason Vas Dias 2005-11-08 23:07:21 UTC
Very sorry for the long delay in processing this bug - it definitely seems to be 
fixed now with the latest RHEL-3 perl version : perl-5.8.0-90.2 . I've just
successfully ran the same command :  perl -MCPAN -e 'install Digest::MD5;'
and it downloaded, built and installed Digest-MD5-2.33 and its prerequisite
Digest-1.13 without any problems - this was done as root. This was done with
the existing upstream MakeMaker 6.03 version shipped with perl-5.8.0-90.2 / 
perl-5.8.0-89.10. Many other issues were also fixed with perl-5.8.0-90.2 would
could explain why MakeMaker now works - does it still fail for you with 
perl-5.8.0-89.10 ? 


Note You need to log in before you can comment on or make changes to this bug.