Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156590 - "Username:", "Please enter usename" message is no display on gdm
Summary: "Username:", "Please enter usename" message is no display on gdm
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-05-02 06:10 UTC by sangu
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-04 13:44:01 UTC


Attachments (Terms of Use)
Use unsigned comparison for detecting end of string (deleted)
2005-05-03 12:33 UTC, Miloslav Trmač
no flags Details | Diff

Description sangu 2005-05-02 06:10:05 UTC
Description of problem:
gdm has no "Username:", "Please enter usename"  messages.

Version-Release number of selected component (if applicable):
gdm-2.6.0.8-11

How reproducible:
always

Steps to Reproduce:
1.Run level 5 booting
2.
3.
  
Actual results:


Expected results:


Additional info:
locale ko_KR.UTF-8

Comment 1 Miloslav Trmač 2005-05-03 11:55:02 UTC
Similar problem in cs_CZ.UTF-8, strings end at first non-ASCII character.
Looks like gdm-2.6.0.8-process-all-messages stops does
q = p;
while (*q >= ' ')
  q++;
with q being "const gchar *", i.e. sign-extended to < 0 (and < ' ') for
non-ASCII characters

Comment 2 Miloslav Trmač 2005-05-03 12:33:19 UTC
Created attachment 113958 [details]
Use unsigned comparison for detecting end of string

This patch against gdm-2.6.0.8-process-all-messages.patch fixes it.

Comment 3 Ray Strode [halfline] 2005-05-03 14:24:07 UTC
Thanks Mirek,

I'll try to push this fix through today.

Comment 4 Ray Strode [halfline] 2005-05-04 13:44:01 UTC
Should be fixed.


Note You need to log in before you can comment on or make changes to this bug.