Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1565850 - [ubuntu] rhcs packages do not override ubuntu.com packages [NEEDINFO]
Summary: [ubuntu] rhcs packages do not override ubuntu.com packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z3
: 3.0
Assignee: leseb
QA Contact: Vasu Kulkarni
Aron Gunn
URL:
Whiteboard:
Depends On:
Blocks: 1600697
TreeView+ depends on / blocked
 
Reported: 2018-04-10 22:50 UTC by Vasu Kulkarni
Modified: 2018-07-12 19:43 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-ansible-3.0.32-1.el7cp Ubuntu: ceph-ansible_3.0.32-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 18:20:31 UTC
Target Upstream Version:
kdreyer: needinfo? (ceph-qe-bugs)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 2527 None None None 2018-04-17 14:01:44 UTC
Red Hat Bugzilla 1404515 None CLOSED ceph-ansible should set set apt pinning for deb packages 2019-03-19 21:28:13 UTC
Red Hat Product Errata RHBA-2018:1563 None None None 2018-05-15 18:21:25 UTC

Internal Links: 1404515

Description Vasu Kulkarni 2018-04-10 22:50:14 UTC
Description of problem:

when installing with rhcs variables on ubuntu distro, ceph-ansible should uninstall any upstream packages that come default with ubuntu so that the installation can continue without any conflicts

eg:

cephuser@ceph-clacroix-run125-node3-mon:~$ dpkg -l | grep rbd
ii  librbd1                              10.2.9-0ubuntu0.16.04.1                    amd64        RADOS block device client library
ii  python-rbd                           10.2.9-0ubuntu0.16.04.1                    amd64        Python libraries for the Ceph librbd library
cephuser@ceph-clacroix-run125-node3-mon:~$ dpkg -l | grep rados
ii  librados2                            10.2.9-0ubuntu0.16.04.1                    amd64        RADOS distributed object store client library
ii  libradosstriper1                     10.2.9-0ubuntu0.16.04.1                    amd64        RADOS striping interface
ii  python-rados                         10.2.9-0ubuntu0.16.04.1                    amd64        Python libraries for the Ceph librados library
cephuser@ceph-clacroix-run125-node3-mon:~$ dpkg -l | grep ceph
ii  ceph-common                          10.2.9-0ubuntu0.16.04.1                    amd64        common utilities to mount and interact with a ceph storage cluster
ii  libcephfs1                           10.2.9-0ubuntu0.16.04.1                    amd64        Ceph distributed file system client library
ii  python-cephfs                        10.2.9-0ubuntu0.16.04.1                    amd64        Python libraries for the Ceph libcephfs library

Comment 3 Vasu Kulkarni 2018-04-10 22:51:38 UTC
TASK [ceph-common : install red hat storage ceph mon for debian] ***************
task path: /usr/share/ceph-ansible/roles/ceph-common/tasks/installs/install_debian_rhcs_packages.yml:7

2018-04-10 15:16:34,553 - ceph.ceph - INFO - fatal: [ceph-clacroix-run125-node1-mon]: FAILED! => {"cache_update_time": 1523398548, "cache_updated": false, "changed": false, "failed": true, "msg": "'/usr/bin/apt-get -y -o \"Dpkg::Options::=--force-confdef\" -o \"Dpkg::Options::=--force-confold\"     install 'ceph-mon'' failed: E: Unable to correct problems, you have held broken packages.\n", "rc": 100, "stderr": "E: Unable to correct problems, you have held broken packages.\n", "stderr_lines": ["E: Unable to correct problems, you have held broken packages."], "stdout": "Reading package lists...\nBuilding dependency tree...\nReading state information...\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n ceph-mon : Depends: ceph-base (= 10.2.2-29redhat1xenial) bu
2018-04-10 15:16:34,553 - ceph.ceph - INFO - t it is not going to be installed\n", "stdout_lines": ["Reading package lists...", "Building dependency tree...", "Reading state information...", "Some packages could not be installed. This may mean that you have", "requested an impossible situation or if you are using the unstable", "distribution that some required packages have not yet been created", "or been moved out of Incoming.", "The following information may help to resolve the situation:", "", "The following packages have unmet dependencies:", " ceph-mon : Depends: ceph-base (= 10.2.2-29redhat1xenial) but it is not going to be installed"]}

2018-04-10 15:16:34,594 - ceph.ceph - INFO - fatal: [ceph-clacroix-run125-node3-mon]: FAILED! => {"cache_update_time": 1523398548, "cache_updated": false, "changed": false, "failed": true, "msg": "'/usr/bin/apt-get -y -o \"Dpkg::Options::=--force-confdef\" -o \"Dpkg::Options::=--force-confold\"     install 'ceph-mon'' failed: E: Unable to correct problems, you have held broken packages.\n", "rc": 100, "stderr": "E: Unable to correct problems, you have held broken packages.\n", "stderr_lines": ["E: Unable to correct problems, you have held broken packages."], "stdout": "Reading package lists...\nBuilding dependency tree...\nReading state information...\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n ceph-mon : Depends: ceph-base (= 10.2.2-29redhat1xenial) bu
2018-04-10 15:16:34,595 - ceph.ceph - INFO - t it is not going to be installed\n", "stdout_lines": ["Reading package lists...", "Building dependency tree...", "Reading state information...", "Some packages could not be installed. This may mean that you have", "requested an impossible situation or if you are using the unstable", "distribution that some required packages have not yet been created", "or been moved out of Incoming.", "The following information may help to resolve the situation:", "", "The following packages have unmet dependencies:", " ceph-mon : Depends: ceph-base (= 10.2.2-29redhat1xenial) but it is not going to be installed"]}

2018-04-10 15:16:34,743 - ceph.ceph - INFO - fatal: [ceph-clacroix-run125-node2-mon]: FAILED! => {"cache_update_time": 1523398549, "cache_updated": false, "changed": false, "failed": true, "msg": "'/usr/bin/apt-get -y -o \"Dpkg::Options::=--force-confdef\" -o \"Dpkg::Options::=--force-confold\"     install 'ceph-mon'' failed: E: Unable to correct problems, you have held broken packages.\n", "rc": 100, "stderr": "E: Unable to correct problems, you have held broken packages.\n", "stderr_lines": ["E: Unable to correct problems, you have held broken packages."], "stdout": "Reading package lists...\nBuilding dependency tree...\nReading state information...\nSome packages could not be installed. This may mean that you have\nrequested an impossible situation or if you are using the unstable\ndistribution that some required packages have not yet been created\nor been moved out of Incoming.\nThe following information may help to resolve the situation:\n\nThe following packages have unmet dependencies:\n ceph-mon : Depends: ceph-base (= 10.2.2-29redhat1xenial) bu
2018-04-10 15:16:34,743 - ceph.ceph - INFO - t it is not going to be installed\n", "stdout_lines": ["Reading package lists...", "Building dependency tree...", "Reading state information...", "Some packages could not be installed. This may mean that you have", "requested an impossible situation or if you are using the unstable", "distribution that some required packages have not yet been created", "or been moved out of Incoming.", "The following information may help to resolve the situation:", "", "The following packages have unmet dependencies:", " ceph-mon : Depends: ceph-base (= 10.2.2-29redhat1xenial) but it is not going to be installed"]}

Comment 4 Ken Dreyer (Red Hat) 2018-04-16 22:43:24 UTC
ceph-ansible should configure Apt repositories with pinning, so that the RHCS packages always override whatever is installed.

This was added to ceph-ansible in https://github.com/ceph/ceph-ansible/issues/1182 , and accidentally removed in https://github.com/ceph/ceph-ansible/pull/1734 . rhcs.pref.j2 is still in the tree, so we should reuse it.

Comment 5 leseb 2018-04-17 14:01:45 UTC
Sorry for the regression.

Comment 6 Ken Dreyer (Red Hat) 2018-04-27 22:52:05 UTC
Will be in v3.0.32 when that is tagged upstream.

Comment 12 Vasu Kulkarni 2018-05-11 02:55:39 UTC
Verified.=

Comment 15 errata-xmlrpc 2018-05-15 18:20:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1563


Note You need to log in before you can comment on or make changes to this bug.