Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156584 - PAM's pam_access is broken
Summary: PAM's pam_access is broken
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pam
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-02 02:28 UTC by W. Michael Petullo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-02 06:51:43 UTC


Attachments (Terms of Use)

Description W. Michael Petullo 2005-05-02 02:28:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.7) Gecko/20050416 Epiphany/1.6.1

Description of problem:
The pam_access module is broken.

Version-Release number of selected component (if applicable):
pam-0.79-6

How reproducible:
Always

Steps to Reproduce:
1.  Add the following line to /etc/pam.d/system-auth:

auth        required      pam_access.so

2.  Try to login as a user.

Actual Results:  [mike@imp]$ su - someuser
password:
su: incorrect password

/var/log/messages says:

[...]
May  1 21:18:35 imp su: PAM unable to resolve symbol: pam_sm_authenticate
May  1 21:18:35 imp su: PAM unable to resolve symbol: pam_sm_setcred
[...]

Expected Results:  I should be able to log in unless /etc/security/access.conf forbids it.

Additional info:

Comment 1 Tomas Mraz 2005-05-02 06:51:43 UTC
pam_access is used only in the account phase not in the authenticate phase.



Note You need to log in before you can comment on or make changes to this bug.