Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156580 - xmltex package should require passivetex
Summary: xmltex package should require passivetex
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xmltex
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-02 02:05 UTC by W. Michael Petullo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-03 15:50:20 UTC


Attachments (Terms of Use)

Description W. Michael Petullo 2005-05-02 02:05:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.7) Gecko/20050416 Epiphany/1.6.1

Description of problem:
The xmltex package does not require passivetex.  However, without passivetex, xmltex will not work.

Version-Release number of selected component (if applicable):
xmltex-20020625-5

How reproducible:
Always

Steps to Reproduce:
Execute "pdfxmltex docbook.fo."


Actual Results:  This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4)
entering extended mode
(./docbook.fo
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, bulgarian, catalan, croatian, czech, danish, dutch, esperanto, e
stonian, finnish, greek, icelandic, irish, italian, latin, magyar, norsk, polis
h, portuges, romanian, russian, serbian, slovak, slovene, spanish, swedish, tur
kish, ukrainian, nohyphenation, loaded.
xmltex version: 2002/06/25 v1.9 (Exp):
(/usr/share/texmf/tex/xmltex/xmltex.cfg)
No File: docbook.cfg

! LaTeX Error: File `fotex.xmt' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: xmt)

Expected Results:  If passivetex is installed, pdfxmltex works fine.

Additional info:

Comment 1 Tim Waugh 2005-05-03 08:57:44 UTC
You have it backwards: it is passivetex that requires xmltex (and the RPM is
tagged appropriately).  It is similar to the relationship between latex and tex.

Comment 2 W. Michael Petullo 2005-05-03 15:40:05 UTC
I am not following your logic.

LaTeX requires TeX.  If I have a LaTeX document, then as a user I would know to
"yum install tetex-latex" because tetex-latex processes LaTeX documents. 
Tetex-latex would bring in tetex and the result would be a working latex program.

But consider the case of xmltex.  If I had a FO document that I wanted to
process, then I would do a "yum install xmltex" because pdfxmltex processes
these documents.  But I would be left with a broken xmltex because passivetex
would not be installed.

Granted, tetex-latex and passivetex are both a collection of TeX macros.  But
tetex-latex also contains the program latex -- passivetex does not contain the
program pdfxmltex.

Comment 3 Tim Waugh 2005-05-03 15:50:20 UTC
The point stands: xmltex does not, of itself, require passivetex.  Putting such
a dependency in the RPM is incorrect.

If you don't like the tex/latex analogy, try xsltproc/docbook-style-xsl.  Should
libxslt require the DocBook stylesheets? (No, it shouldn't.)

FWIW, you probably should run "yum install xmlto" anyway. :-)

Comment 4 W. Michael Petullo 2005-05-03 15:53:08 UTC
Okay, you got me.  Thanks, Tim.


Note You need to log in before you can comment on or make changes to this bug.