Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156572 - patch breaks keyReleaseEvent()
Summary: patch breaks keyReleaseEvent()
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-01 23:24 UTC by Joel Uckelman
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-06-20 13:49:04 UTC


Attachments (Terms of Use)
moc file for test program (deleted)
2005-05-01 23:26 UTC, Joel Uckelman
no flags Details
test program (deleted)
2005-05-01 23:27 UTC, Joel Uckelman
no flags Details

Description Joel Uckelman 2005-05-01 23:24:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
QWidget::keyReleaseEvent() is supposed to receive a QKeyEvent * which reveals which key was released to trigger the event. This works with an unpatched Qt 3.3.4, but in the Fedora version QKeyEvent::key() is always 0, regardless of what key was released.

This prevents from working properly any program which both needs to know about key releases and uses Qt.

Version-Release number of selected component (if applicable):
qt-3.3.4-0.fc3.0

How reproducible:
Always

Steps to Reproduce:
1. Build the attached program: gcc -I/usr/lib/qt-3.3/mkspecs/default -I$QTDIR/include -L$QTDIR/lib -lqt-mt moc_test.cpp test.cpp -o test
2. Run: ./test
3. Focus the window.
4. Press and release your favorite key.


Actual Results:  I like the spacebar, so what I see is:

pressed: 32
released: 0

Expected Results:  I should see:

pressed: 32
released: 32

Additional info:

Comment 1 Joel Uckelman 2005-05-01 23:26:03 UTC
Created attachment 113912 [details]
moc file for test program

Comment 2 Joel Uckelman 2005-05-01 23:27:59 UTC
Created attachment 113913 [details]
test program

Comment 3 Joel Uckelman 2005-05-02 03:08:45 UTC
I've now pinned down (roughly) which bunch of patches the problem comes from: If
you build without immodule support, keyReleaseEvent() works properly; otherwise not.


Comment 4 Ngo Than 2005-06-14 13:28:00 UTC
it's now fixed in qt-3.3.4-15. It will be available in rawhide soon.

For FC3-update, it will be available next week.

Many thanks for your report.

Comment 5 Dawid Gajownik 2006-06-19 22:13:15 UTC
This seems to be broken again in qt-3.3.6-0.1.fc5 from updates-testing repo.

Comment 6 Rex Dieter 2006-06-19 23:32:12 UTC
How exactly does it "seem" broken again?

Comment 7 Dawid Gajownik 2006-06-20 10:38:00 UTC
Press ALT+F2 and then type program name (for instance "kate"). Hit TAB key to
mark "Options" button. Press SPACE.

With qt-3.3.6-0.1.fc5 (this time from updates repo) button "Options" is only
pressed in.
Downgrading to qt-3.3.5-13 resolves the problem - pressing SPACE key gives the
same result as mouse click on "Options" button.

Comment 8 Ngo Than 2006-06-20 13:49:04 UTC
I can reproduce this problem here. It's now fixed. The fix will be included
in next qt-3.3.6-0.2.fc5. I will build this new version for FC5 updates soon.

Thanks for your report.

Comment 9 Dawid Gajownik 2006-06-20 16:21:08 UTC
Thanks!


Note You need to log in before you can comment on or make changes to this bug.