Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156504 - Rendering for Punjabi (pa_IN) is incorrect
Summary: Rendering for Punjabi (pa_IN) is incorrect
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: qt
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: Indic 176344
TreeView+ depends on / blocked
 
Reported: 2005-05-01 10:23 UTC by A S Alam
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-24 10:10:54 UTC


Attachments (Terms of Use)
Kate with Problem (deleted)
2005-05-01 10:23 UTC, A S Alam
no flags Details
Gedit with correct rendering (deleted)
2005-05-01 10:25 UTC, A S Alam
no flags Details

Description A S Alam 2005-05-01 10:23:32 UTC
Description of problem:
There is Incorrect rendering for a combination in QT for Punjabi Language
(pa-IN), so all KDE based Applications are shows that Combination incorrect,

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. Open kate
2. Change Language pa (IIMF)
3. (with Inscipt Keyboard) Press k + d + u  (U0A15+U0A4D+U039)
  
Actual results:
there is no change in character postion,

Expected results:
U039 character should put under U0A15 (Below-base form)


Additional info:
1)To understand more clearly, You can use same case with GEDIT, which render
Punjabi Character
correctly

2) Punjabi Rendering Reference
 
http://www.microsoft.com/typography/otfntdev/gurmukot/features.aspx
 has 
Below-base form
where this rendering is represented

attching screenshots for QT(kate) as well GTK(gedit)

Comment 1 A S Alam 2005-05-01 10:23:32 UTC
Created attachment 113901 [details]
Kate with Problem

Comment 2 A S Alam 2005-05-01 10:25:24 UTC
Created attachment 113902 [details]
Gedit with correct rendering

Gedit shows same character combination (U0A4d+U0A39) with correct rendering

Comment 3 Ngo Than 2005-05-02 09:03:58 UTC
do you know how i can change language to pa in iiimf for testing?

Comment 4 A S Alam 2005-05-02 10:00:43 UTC
Click on Icon and then u can add (Add/Remove) Punjabi on White box. 

Comment 5 Ngo Than 2005-06-27 08:34:46 UTC
It's now fixed in qt-3_3_3-9_4. I will upload the new version on
ftp:/people.redhat.com/rhel3 next day. If we do update for RHEL3, The fix will be 
included. Many thanks for your report.


Comment 6 A S Alam 2005-06-29 05:52:19 UTC
than, 
thanks for help
I have RHEL4 and Fedora Core 4, from where I get package  to install for any of one?

Comment 7 Ngo Than 2005-06-29 08:48:06 UTC
For RHEL4 you will find it on ftp:/people.redhat.com/rhel4 soon. And for FC4,
you could use the qt-3.3.4-16 from rawhide.

I plan to update qt-3.3.5 for FC4 soon. It's the reason why i don't want to do
qt update for FC4 now


Comment 8 A S Alam 2005-06-30 03:22:21 UTC
thanks Ngo Than!

for RHEL4, qt rendering is perfect:)

Comment 9 A S Alam 2005-10-21 13:27:07 UTC
this is not fixed in U2, can u please check

Comment 12 Ngo Than 2006-03-30 18:22:25 UTC
A S Alam, could you please verify whether the qt-3.3.3-9.4 fixes the problem?
you find it on ftp://people.redhat.com/than/rhel4/

Comment 13 A S Alam 2006-03-31 03:42:13 UTC
yes, that is work fine and issue is fixed

Comment 15 A S Alam 2006-05-24 10:10:54 UTC
Closing bug as this issue is fixed


Note You need to log in before you can comment on or make changes to this bug.