Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156488 - kernel cannot load initrd image from xfs filesystem
Summary: kernel cannot load initrd image from xfs filesystem
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yaboot
Version: 4
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-01 04:16 UTC by Eugene Savelov
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-28 20:08:48 UTC


Attachments (Terms of Use)

Description Eugene Savelov 2005-05-01 04:16:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.6) Gecko/20050328 Firefox/1.0.2 Fedora/1.0.2-3

Description of problem:
After installing Fedora core4 test2 on an XFS filesystem (typed linux xfs when booting from CD), after first reboot yaboot loaded linux kernel, but it failed to mount root filesystem. Probably because neither xfs module was compiled in kernel, nor it was able to load initrd image with xfs kernel module. After I moved kernel and initrd to ext3 filesystem and rerun /sbin/ybin, fedora core2 started succesfully from xfs root filesystem.

Version-Release number of selected component (if applicable):
yaboot-1.3.12-9 kernel-2.6.11-1.1226_FC4

How reproducible:
Always

Steps to Reproduce:
1. run installer with 'linux xfs' on powerpc
2. format root filesystem with xfs
3. install linux , boot loader
  

Actual Results:  Kernel error so it can not mount root


Expected Results:  It should load initrd image , load xfs kernel module and mount root filesystem

Additional info:

Comment 1 Paul Nasrat 2005-11-28 20:08:48 UTC
XFS is totally, 100% unsupported.  

From the src:
# Boot with "linux xfs"
# at the boot: prompt will let you make new xfs filesystems
# in the installer.  Bugs filed when you use this will be closed
# WONTFIX.




Note You need to log in before you can comment on or make changes to this bug.