Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156471 - The Application "gnomemeeting" has quit unexpectedly.
Summary: The Application "gnomemeeting" has quit unexpectedly.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnomemeeting
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-30 22:44 UTC by Ricky Ng-Adam
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-27 09:25:46 UTC


Attachments (Terms of Use)
Backtrace of a crash (deleted)
2005-06-26 00:38 UTC, Alex Eskin
no flags Details
The attached patch (untested) should fix this bug (deleted)
2005-06-29 22:29 UTC, Alex Eskin
no flags Details | Diff

Description Ricky Ng-Adam 2005-04-30 22:44:07 UTC
Description of problem:

launch gnomemeeting result in crash

Version-Release number of selected component (if applicable):

gnomemeeting-1.2.1-1

How reproducible:

always

Steps to Reproduce:
1. start program
2.
3.
  
Actual results:

crash (with window of "first time configuration druid" behind the crash popup)

Expected results:

no crash

Additional info:

[rngadam@localhost ~]$ gnomemeeting -d 6
2005/04/30 18:40:56.750   0:00.298                 gnomemeeting Detected audio p
lugins: ALSA,OSS,Quicknet
2005/04/30 18:40:56.799   0:00.317                 gnomemeeting Detected video p
lugins: Picture,AVC,V4L
2005/04/30 18:40:56.844   0:00.362                 gnomemeeting Detected the fol
lowing audio input devices: Sound Fusion CS46xx,Default with plugin ALSA
2005/04/30 18:40:56.863   0:00.382                 gnomemeeting Detected the fol
lowing audio output devices: Sound Fusion CS46xx,Default with plugin ALSA
2005/04/30 18:40:56.886   0:00.404                 gnomemeeting Detected the fol
lowing video input devices: MovingLogo,StaticPicture with plugin Picture
2005/04/30 18:40:57.917   0:01.436                 gnomemeeting GnomeMeeting ver
sion 1.2.1
2005/04/30 18:40:57.937   0:01.455                 gnomemeeting OpenH323 version
 1.15.3
2005/04/30 18:40:57.937   0:01.476                 gnomemeeting PWLIB version 1. 8.4
2005/04/30 18:40:57.959   0:01.477                 gnomemeeting GNOME support en
abled
2005/04/30 18:40:57.978   0:01.496                 gnomemeeting Fullscreen suppo
rt enabled
2005/04/30 18:40:57.978   0:01.517                 gnomemeeting DBUS support dis
abled
2005/04/30 18:40:57.999   0:01.518                 gnomemeeting Quicknet hardwar
e support enabled
2005/04/30 18:40:58.047   0:01.565                 gnomemeeting H323    Added ca
pability: H.261-QCIF <1>
2005/04/30 18:40:58.096   0:01.615                 gnomemeeting H323    Added ca
pability: H.261-CIF <2>
2005/04/30 18:40:58.116   0:01.651                 gnomemeeting H323    Added ca
pability: UserInput/hookflash <3>
2005/04/30 18:40:58.134   0:01.671                 gnomemeeting H323    Added ca
pability: UserInput/basicString <4>
2005/04/30 18:40:58.154   0:01.692                 gnomemeeting H323    Added ca
pability: UserInput/dtmf <5>
2005/04/30 18:40:58.175   0:01.712                 gnomemeeting H323    Added ca
pability: UserInput/RFC2833 <6>
2005/04/30 18:40:58.218   0:01.736                 gnomemeeting H323    Started
listener Listener[ip$*:32776]
2005/04/30 18:40:58.258   0:01.776        H323 Listener:a1c3f78 H323    Awaiting
 TCP connections on port 32776
2005/04/30 18:40:58.259   0:01.796        H323 Listener:a1c3f78 TCP     Waiting
on socket accept on ip$*:32776

Comment 1 Ricky Ng-Adam 2005-04-30 22:47:11 UTC
with strace...

writev(10, [{"GIOP\1\2\1\0\271\0\0\0", 12},
{"\300W\341\277\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\364\222"..., 185}], 2) = 197
futex(0x93849c8, FUTEX_WAKE, 1)         = 1
writev(10, [{"GIOP\1\2\1\0\261\0\0\0", 12},
{"\300W\341\277\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\364\222"..., 177}], 2) = 189
futex(0x93849c8, FUTEX_WAKE, 1)         = 1
writev(10, [{"GIOP\1\2\1\0\255\0\0\0", 12},
{"pW\341\277\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\364\222\\\300"..., 173}], 2) = 185
futex(0x93849c8, FUTEX_WAKE, 1)         = 1
pipe([40, 41])                          = 0
socket(PF_INET6, SOCK_STREAM, IPPROTO_IP) = 42
ioctl(42, FIONBIO, [1])                 = 0
fcntl64(42, F_SETFD, FD_CLOEXEC)        = 0
setsockopt(42, SOL_SOCKET, SO_REUSEADDR, [1], 4) = 0
bind(42, {sa_family=AF_INET6, sin6_port=htons(0), inet_pton(AF_INET6, "::",
&sin6_addr), sin6_flowinfo=0, sin6_scope_id=0}, 28) = 0
getsockname(42, {sa_family=AF_INET6, sin6_port=htons(32782), inet_pton(AF_INET6,
"::", &sin6_addr), sin6_flowinfo=0, sin6_scope_id=0}, [28]) = 0
listen(42, 100)                         = 0
gettimeofday({1114901150, 600588}, NULL) = 0
time(NULL)                              = 1114901150
write(2, "2005/04/30 18:45:50.600\t", 242005/04/30 18:45:50.600 ) = 24
gettimeofday({1114901150, 600952}, NULL) = 0
write(2, "  0:13.886", 10  0:13.886)              = 10
write(2, "\t", 1        )                       = 1
write(2, "           gnomemeeting", 23           gnomemeeting) = 23
write(2, "\t", 1        )                       = 1
write(2, "H323\tStarted listener ", 22H323      Started listener ) = 22
write(2, "Listener[", 9Listener[)                = 9
write(2, "ip$*:32782", 10ip$*:32782)              = 10
write(2, "]", 1])                        = 1
write(2, "\n", 1
)                       = 1
geteuid32()                             = 500
mmap2(NULL, 266240, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0x645e000
mprotect(0x645e000, 4096, PROT_NONE)    = 0
clone(child_stack=0x649e4c4,
flags=CLONE_VM|CLONE_FS|CLONE_FILES|CLONE_SIGHAND|CLONE_THREAD|CLONE_SYSVSEM|CLONE_SETTLS|CLONE_PARENT_SETTID|CLONE_CHILD_CLEARTID|CLONE_DETACHED,
parent_tidptr=0x649ebf8, {entry_number:6, base_addr:0x649ebb0, limit:1048575,
seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0,
useable:1}, child_tidptr=0x649ebf8) = 4313
writev(10, [{"GIOP\1\2\1\0\255\0\0\0", 12},
{"\300W\341\277\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\364\222"..., 173}], 2) = 185
futex(0x93849c8, FUTEX_WAKE, 1)         = 1
pipe([43, 44])                          = 0
2005/04/30 18:45:50.891   0:14.178        H323 Listener:952ece0 H323    Awaiting
TCP connections on port 32782
2005/04/30 18:45:50.892   0:14.186        H323 Listener:952ece0 TCP     Waiting
on socket accept on ip$*:32782
pipe([45, 46])                          = 0
socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 47
bind(47, {sa_family=AF_INET, sin_port=htons(0),
sin_addr=inet_addr("127.0.0.1")}, 16) = 0
getsockname(47, {sa_family=AF_INET, sin_port=htons(32783),
sin_addr=inet_addr("127.0.0.1")}, [16]) = 0
listen(47, 5)                           = 0
socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 48
connect(48, {sa_family=AF_INET, sin_port=htons(5335),
sin_addr=inet_addr("127.0.0.1")}, 16) = 0
getsockname(48, {sa_family=AF_INET, sin_port=htons(37609),
sin_addr=inet_addr("127.0.0.1")}, [16]) = 0
setsockopt(48, SOL_TCP, TCP_NODELAY, [1], 4) = 0
setsockopt(48, SOL_SOCKET, SO_LINGER, {onoff=0, linger=0}, 8) = 0
send(48, "SWOP\1\0\1\0t\0\0\0\0\0\0\0\3\0\0\0\0\6\0\0\0dns-sd\16"..., 128, 0) = 128
select(49, [48], NULL, NULL, {5, 0})    = 1 (in [48], left {4, 997000})
recv(48, "SWOP\1\0\1\0004\0\0\0\0\0\0\0\16\0\0\0\0\6\0\0\0DNS-SD"..., 4192, 0) = 64
geteuid32()                             = 500
mmap2(NULL, 266240, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0x2ad4000
mprotect(0x2ad4000, 4096, PROT_NONE)    = 0
clone(child_stack=0x2b144c4,
flags=CLONE_VM|CLONE_FS|CLONE_FILES|CLONE_SIGHAND|CLONE_THREAD|CLONE_SYSVSEM|CLONE_SETTLS|CLONE_PARENT_SETTID|CLONE_CHILD_CLEARTID|CLONE_DETACHED,
parent_tidptr=0x2b14bf8, {entry_number:6, base_addr:0x2b14bb0, limit:1048575,
seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0,
useable:1}, child_tidptr=0x2b14bf8) = 4314
futex(0x9534540, FUTEX_WAIT, 1, NULL)   = 0
futex(0x953453c, FUTEX_WAIT, 2, NULL)   = 0
futex(0x953453c, FUTEX_WAKE, 1)         = 0
futex(0x9534524, FUTEX_WAIT, 2, NULL)   = 0
futex(0x9534524, FUTEX_WAKE, 1)         = 0
writev(10, [{"GIOP\1\2\1\0\255\0\0\0", 12}, {"
W\341\277\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\364\222\\\300"..., 173}], 2) = 185
futex(0x93849c8, FUTEX_WAKE, 1)         = 1
writev(10, [{"GIOP\1\2\1\0\255\0\0\0", 12}, {"
W\341\277\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\364\222\\\300"..., 173}], 2) = 185
futex(0x93849c8, FUTEX_WAKE, 1)         = 1
writev(10, [{"GIOP\1\2\1\0\255\0\0\0", 12}, {"
W\341\277\3\0\0\0\0\0\0\0\34\0\0\0\0\0\0\0\364\222\\\300"..., 173}], 2) = 185
futex(0x93849c8, FUTEX_WAKE, 1)         = 1
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
write(3, "\22\0\30\0G\0\240\2(\0\0\0)\0\0\0 \2z\1\22\0\0\0\24\2\0"..., 1040) = 1040
write(3, " \0\2\0\0\0\0\0", 8)          = 8
write(3, "+\0\1\0", 4)                  = 4
read(3, 0xbfe155b4, 32)                 = -1 EAGAIN (Resource temporarily
unavailable)
select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
read(3, "\34\256\303\1G\0\240\2(\0\0\0\215\30>\0\0/\f\10\200\256"..., 32) = 32
read(3, "\23\366\310\1M\0\240\2M\0\240\2\0\0\0\0\230\366\253\277"..., 32) = 32
read(3, "\23\366\314\1N\0\240\2N\0\240\2\0\0\0\0\230\366\253\277"..., 32) = 32
read(3, "\23\366\320\1O\0\240\2O\0\240\2\0\0\0\0\230\366\253\277"..., 32) = 32
read(3, "\23\366\346\1\\\0\240\2\\\0\240\2\0\0\240\2\0\0\0\0\1\0"..., 32) = 32
read(3, "\23\366\350\1Q\0\240\2Q\0\240\2\0\0\240\2\1\0\0\300\1\0"..., 32) = 32
read(3, "\23\366\352\1P\0\240\2P\0\240\2\0\0\240\2\1\0\0\300\1\0"..., 32) = 32
read(3, "\34\301\354\1G\0\240\2#\0\0\0\215\30>\0\0\30>\0\250yC\t"..., 32) = 32
read(3, "\1\2\362\1\0\0\0\0\3328\200\2\4\0\0\0\0\0\0\0hB\36\0\200"..., 32) = 32
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD,
child_tidptr=0xb7efd708) = 4315
waitpid(4315, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0) = 4315
--- SIGCHLD (Child exited) @ 0 (0) ---
sigreturn()                             = ? (mask now [SEGV])
exit_group(1)                           = ?


Comment 2 Jeremy Katz 2005-05-23 23:12:40 UTC
This works for me -- can you try with the current devel tree?

Comment 3 Alex Eskin 2005-06-26 00:38:08 UTC
Created attachment 115983 [details]
Backtrace of a crash

Comment 4 Alex Eskin 2005-06-29 22:29:21 UTC
Created attachment 116150 [details]
The attached patch (untested) should fix this bug

If the lastname gconf key is not set, gnomemeeting
attempts to dereference a NULL pointer at
zeroconf_publisher.cpp line 182.

The attached patch is an "obvious" fix, but I did
not have time to test it.

Comment 5 Ricky Ng-Adam 2006-02-25 22:49:42 UTC
gnomemeeting is now ekiga? I can't reproduce the problem in FC5t3 (ekiga-1.99.1-1).

Comment 6 Alexander Larsson 2006-02-27 09:25:46 UTC
Cool. Closing then.


Note You need to log in before you can comment on or make changes to this bug.