Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156470 - xterm fails to start with "ioctl() failed on TIOCSETP"
Summary: xterm fails to start with "ioctl() failed on TIOCSETP"
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xterm
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
: 158853 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-30 22:40 UTC by Ralf Ertzinger
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-06 06:18:26 UTC


Attachments (Terms of Use)
strace -tt -f -F -s 128 xterm (deleted)
2005-04-30 22:40 UTC, Ralf Ertzinger
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org (Old) 3212 None None None Never

Description Ralf Ertzinger 2005-04-30 22:40:20 UTC
Description of problem:
Trying to start xterm yields the following message:

xterm: Error 23, errno 22: Invalid argument
Reason: spawn: ioctl() failed on TIOCSETP

This just happens on my iBook, the athlon box is fine.
I cannot see anything obviously fishy in the strace (attached)

Version-Release number of selected component (if applicable):
xterm-200-6

How reproducible:
Always

Steps to Reproduce:
1. open a different terminal program
2. try to start xterm
3.
  
Actual results:
xterm fails to start

Expected results:
xterm starts

Additional info:

Comment 1 Ralf Ertzinger 2005-04-30 22:40:20 UTC
Created attachment 113895 [details]
strace -tt -f -F -s 128 xterm

Comment 2 Mike A. Harris 2005-05-05 01:27:34 UTC
Please file a bug report in X.Org bugzilla to track this issue,
which is located at http://bugs.freedesktop.org in the "xorg" component.

Once you've filed your report to X.Org, if you paste the URL here,
Red Hat will track the issue in X.Org bugzilla with upstream developers,
and will review any fixes that become available for potential inclusion
in future Fedora Core updates.

Comment 3 Mike A. Harris 2005-05-05 01:28:12 UTC
Setting status to "NEEDINFO", awaiting upstream bug report URL.

Comment 4 Ralf Ertzinger 2005-05-05 13:04:15 UTC
Bug has 

Comment 5 Ralf Ertzinger 2005-05-05 13:04:58 UTC
Bug has been added to fdo bugzilla.

Comment 6 Mike A. Harris 2005-05-06 06:18:26 UTC
Thanks for the URL.

I've added http://freedesktop.org/bugzilla/show_bug.cgi?id=3212
to our internal tracker.

Setting status to "UPSTREAM" for tracking via Xorg bugzilla.

Thanks again.

Comment 7 Thomas E. Dickey 2005-05-15 23:01:01 UTC
perhaps this (xterm patch #202):
ignore error in the I/O initialization that tries to set the tty to 7-bit input 
for the case where eightBitInput resource is false (Debian #298551).

Comment 8 Ralf Ertzinger 2005-05-17 08:54:18 UTC
Well, setting 'XTerm*eightBitInput: true' magically makes xterm work again, so
it looks like we have a winner here. The only thing that puzzles me is that
(according to the man page) this should be the default setting.

Comment 9 Thomas E. Dickey 2005-05-17 09:00:49 UTC
The manpage documents what the upstream source does.
downstream packages may change this (though it would
be nice if they updated the manpage as well).
The eightBitInput resource is probably being set false
to appease users of Midnight Commander, who want the
Alt key to send an ESC.  A similar effect can be obtained
using the metaSendsEscape resource.

Comment 10 Mike A. Harris 2005-05-26 08:00:52 UTC
*** Bug 158853 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.