Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1564697 - Reconfig for VM fails
Summary: Reconfig for VM fails
Keywords:
Status: CLOSED DUPLICATE of bug 1517112
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.8.4
Assignee: William Fitzgerald
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-06 23:23 UTC by Tuan
Modified: 2018-04-11 13:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 21:14:27 UTC
Category: Bug
Cloudforms Team: CFME Core


Attachments (Terms of Use)
Customer steps to reproduce. (deleted)
2018-04-06 23:23 UTC, Tuan
no flags Details

Description Tuan 2018-04-06 23:23:51 UTC
Created attachment 1418384 [details]
Customer steps to reproduce.

Description of problem:

Reconfigure VM fails. with undefined method.
NoMethodError: undefined method `check_quota' for #<MiqAeMethodService::MiqAeServiceVmReconfigureRequest:0x0000001002ef08>

VMware

Version-Release number of selected component (if applicable):
5.8.3.4

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 William Fitzgerald 2018-04-09 15:13:49 UTC
I was able to reproduce this using group quota.  I think we are missing a PR to be backported. Still looking into this.

Billy

Comment 3 William Fitzgerald 2018-04-09 20:30:14 UTC
This issue was resolved previously.

We need these two PR back ported:

https://github.com/ManageIQ/manageiq/pull/16626

https://github.com/ManageIQ/manageiq-automation_engine/pull/97

Thanks

Billy

Comment 4 Satoe Imaishi 2018-04-10 21:14:27 UTC

*** This bug has been marked as a duplicate of bug 1517112 ***


Note You need to log in before you can comment on or make changes to this bug.