Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156461 - left-over gdmfifo may hang boot
Summary: left-over gdmfifo may hang boot
Keywords:
Status: CLOSED DUPLICATE of bug 156355
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-30 20:22 UTC by Alexandre Oliva
Modified: 2014-03-17 02:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-02 16:04:53 UTC


Attachments (Terms of Use)

Description Alexandre Oliva 2005-04-30 20:22:46 UTC
If the following conditions are met:

- /var/gdm/.gdmfifo is left over across a reboot (say, the box crashes while gdm
is running, or you're testing suspend&resume from the text console, and suspend
works but resume doesn't :-/

- early gdm is not enabled

- any init.d script fails to start while booting up

then boot will hang within failure(), because it attempts to write to a pipe and
nobody is listening.

Ideally, we'd clean up /var/gdm/.gdmfifo before running any script that might
call failure(), but there are scripts that do so before root or /var are made
read-write, e.g., the very commands that remount / read-write and that mount
other filesystems.  The latter may actual fail without any undesirable
consequences for filesystems marked to be mounted by default with fs_passno ==
0, such that boot doesn't stop if the removable media containing them happen to
not be present.  (guess what happened to me during my last trip, to which I
didn't take my external hard drive along with my notebook :-)

I suppose it wouldn't be such a bad idea to move /var/gdm/.gdmfifo to some
directory that is rw right from the beginning such as /dev (assuming udev) or
somesuch, like notting suggested for another lvm-related problem.

Comment 1 Bill Nottingham 2005-05-02 16:04:53 UTC

*** This bug has been marked as a duplicate of 156355 ***


Note You need to log in before you can comment on or make changes to this bug.