Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156460 - "Invalid compressed format (err=1)" error on boot
Summary: "Invalid compressed format (err=1)" error on boot
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-30 18:03 UTC by Dawid Zamirski
Modified: 2015-01-04 22:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-05 19:59:34 UTC


Attachments (Terms of Use)

Description Dawid Zamirski 2005-04-30 18:03:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
Hello

Since the update to rawhide20050427 I'm unable to boot the system with any kernel, including the most recent 1276 build, except 2.6.11-1.1240_FC4 which works ok. Higher builds of the kernel throw the "Invalid compressed format" error. I was able to boot 126x kernels before the update. I tried to revert back initscripts an mkinitrd packages to 8.07-1.x86_64 and 4.2.8-1.x86_64 respectively, but this didn't solve the problem. I also disabled SELinux and checked my file system with reiserfsck but this didn't help either. My system specs are below:

CPU: AMD Athlon 64 3500+
Motherboard: MSI K8T Neo2 Platinum
HDD: Seagate ST3200822A and WDC WD1200JB - both connected to the standard IDE controller.
File system: reiserfs on all partitions inluding /boot




Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1276_FC4

How reproducible:
Always

Steps to Reproduce:
1. Turn on the computer
2. Select any kernel in GRUB (except 1240)
3. Boot selected kernel

Actual Results:  Error message "System halted" "Invalid Comressed format (err=1)"
  

Expected Results:  system startup

Additional info:

[root@athlon64 ~]# rpm -q mkinitrd
mkinitrd-4.2.9-1
[root@athlon64 ~]# rpm -q initscripts
initscripts-8.09-1
[root@athlon64 ~]# rpm -q kernel
kernel-2.6.11-1.1240_FC4
kernel-2.6.11-1.1251_FC4
kernel-2.6.11-1.1253_FC4
kernel-2.6.11-1.1258_FC4
kernel-2.6.11-1.1261_FC4
kernel-2.6.11-1.1267_FC4
kernel-2.6.11-1.1268_FC4
kernel-2.6.11-1.1275_FC4
kernel-2.6.11-1.1276_FC4
[root@athlon64 ~]# rpm -q grub
grub-0.95-12

Comment 1 Dave Jones 2005-05-01 08:03:13 UTC
can you try running memtest for a while ? This smells like bad memory.
Especially as this is the only instance of this we've seen reported, and I've
personally run all recent x86-64 kernels on several different models.


Comment 2 Dawid Zamirski 2005-05-02 13:29:33 UTC
Ok, I'll do the testing when I get back home from work. I doubt that it's a 
memory problem because it happened just right after 04/27 rawhide update and 
the before the update all the kernels booted up correctly. I suspect it's 
caused by reiserfs as /boot fielsystem.. 

Comment 3 Dawid Zamirski 2005-05-02 22:57:22 UTC
Hello again :-)

Memtest passsed sucessfully, so that's not the RAM issue. I played with kernels
installed and discovered that suddenly 1275 boots ok (it was failing when I
checked it after the 04/27 update). Some of my kernels give slightly different
error messges but all of them seem to be realtd to the compressed kernel image.

Builds 1251 and 1268 throw the following error:
Error 13: Invalid or unsupported executable format.

Build 1261:
RAMDISK: ran out of compressed data
Kernel panic - not syncing: VFS: unable to mount fs on unknown-block(22,2)

The rest of my kernels throw just the "Invalid compressed format" message.

I'll perform clean reinstall of my system after FC4T3 comes out because I have
too much mess on my system which, I think, is the cause of the problems. 

Comment 4 Dawid Zamirski 2005-05-13 00:02:57 UTC
Update

I have just made a clean install of FC4T3 and kernel image decompressess
correctly, however right after that it karshes with the following message:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(22,2)

Now, I'm going to make another attempt, but I will change filesystem to ext3 on
/boot 

Comment 5 Dawid Zamirski 2005-05-13 00:36:38 UTC
Ok, I'm back with good news :-) 

Changing the filesystem to ext3 solved the problem. Another little thing that
has been fixed by the filesystem change was that I was able to see the splash
image in grub - I had a black background before on reiserfs after one of rawhide
updates on FC4T2.

Comment 6 Dan Hollis 2005-05-30 08:52:58 UTC
i can duplicate this also. i opened a more specific bug for this - #159123

Comment 7 Dan Hollis 2005-05-31 04:45:30 UTC
since this is reiserfs specific this should be closed WONTFIX same as 159123.

Comment 8 Peter Jones 2005-06-16 00:02:19 UTC
This sounds like the initrd is corrupt.  Can somebody do this with one that
didn't work:

mkdir tmp
cd tmp
zcat /boot/initrd-VERSION | cpio -dvi

and see if it actually works?

Comment 9 Dan Hollis 2005-06-16 00:29:23 UTC
since this is reiserfs specific this should be closed WONTFIX same as 159123.

Comment 10 Dave Jones 2005-07-05 19:59:34 UTC
reiserfs bugs should be reported in http://bugme.osdl.org

Fedora will inherit any fixes that occur upstream on rebases to newer kernels.


Comment 11 Dan Hollis 2005-07-05 20:50:49 UTC
sadly few kernel developers appear to read bugme.osdl.org


Note You need to log in before you can comment on or make changes to this bug.