Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156459 - USB doesn't work after suspend/resume
Summary: USB doesn't work after suspend/resume
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-30 17:42 UTC by Gabriel Schulhof
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.6.11-1.1282_FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-02 05:45:10 UTC


Attachments (Terms of Use)
suspend/resume-related output from dmesg, including a call from an invalid context, and some "badness". (deleted)
2005-04-30 17:49 UTC, Gabriel Schulhof
no flags Details

Description Gabriel Schulhof 2005-04-30 17:42:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.7.7-2

Description of problem:
This bug is similar to #129405 and #146190.

When I close the lid on my iBook G4, wait for the white LED to start pulsating slowly, then re-open the lid, both my USB mouse and my USB keyboard cease to work. Only a reboot restores USB.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1275_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot.
2. Close the lid.
3. Open the lid.
4. Try to use either a USB mouse or a USB keyboard.  

Actual Results:  Neither the USB keyboard nor the USB mouse works.

Expected Results:  Complete USB recovery and continued normal USB operation.

Additional info:

Comment 1 Gabriel Schulhof 2005-04-30 17:49:02 UTC
Created attachment 113890 [details]
suspend/resume-related output from dmesg, including a call from an invalid context, and some "badness".

Comment 2 David Woodhouse 2005-05-01 08:29:01 UTC
Not PPC-specific -- this is general USB brokenness. Paulus sent patches to David
Brownell a _long_ time ago but they're still not merged. Workaround for now is
to unload ehci_hcd; the OHCI (USB1) driver tends to work. I'll chase them up and
see about putting them in the RPM.

The 'Badness in wait_for_ready at drivers/ide/ide-iops.c:520' is just whinging
about an mdelay -- it's also harmless. Again, it isn't PPC-specific except to
the extent that PPC users seem to be the only people for whom suspend is
reliable enough to actually get used :)

Comment 3 Dave Jones 2005-05-01 08:30:36 UTC
ok, thanks.

For info, theres an IDE update on the way from Alan, (its already in CVS, but is
currently borken -- more fixes tomorrow). That may fix the badness in ide.


Comment 4 David Woodhouse 2005-05-01 11:14:41 UTC
The EHCI thing should be fixed in a 1.1280 or later kernel. Since the S390
machines appear to be AWOL from the build farm at the moment that may not turn
up very soon -- in the meantime please test 

http://david.woodhou.se/kernel-2.6.11-1.1279_FC4.dwmw2.ppc.rpm
http://david.woodhou.se/kernel-devel-2.6.11-1.1279_FC4.dwmw2.ppc.rpm

Comment 5 David Woodhouse 2005-05-01 12:00:12 UTC
Actually don't bother testing that -- the IDE changes prevent it from booting.


Comment 6 Dave Jones 2005-05-01 21:41:36 UTC
A 1282 kernel will appear at http://people.redhat.com/davej/kernels/Fedora/FC4
in a while, that *should* hopefully fix the broken IDE problem.


Comment 7 David Woodhouse 2005-05-02 05:45:10 UTC
It boots, I have USB mouse after suspend. 

kallsyms is broken though... note four functions without names:

Debug: sleeping function called from invalid context at include/asm/semaphore.h:71
in_atomic():0, irqs_disabled():1
Call trace:
 [c0019714] __might_sleep+0xd4/0x100
 [c00109d4] pmac_low_i2c_open+0x64/0xa0
 [c03fba0c] 0xc03fba0c
 [c03fbf70] 0xc03fbf70
 [c03f44a8] 0xc03f44a8
 [c04072f4] 0xc04072f4
 [c00b2344] do_ioctl+0x84/0x90
 [c00b23dc] vfs_ioctl+0x8c/0x460
 [c00b2844] sys_ioctl+0x94/0xb0
 [c00048a0] ret_from_syscall+0x0/0x44



Note You need to log in before you can comment on or make changes to this bug.