Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156454 - uninformative error message "not enough space on destination"
Summary: uninformative error message "not enough space on destination"
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner
Version: 3
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-30 15:42 UTC by Paul Jakma
Modified: 2008-02-04 06:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-04 06:06:35 UTC


Attachments (Terms of Use)

Description Paul Jakma 2005-04-30 15:42:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050323 Galeon/1.3.20

Description of problem:
nautilus-cd-burner keeps giving me the following error dialogue when I try drag files into the CD Creator:

Error while link in "burn:///"

There is not enough space on the destination

However:

- /tmp has 1GB free
- my home directory has several GB free
$ df -h /tmp /home/paul
Filesystem            Size  Used Avail Use% Mounted on
tmpfs                1000M   58M  943M   6% /tmp
hibernia:/home/paul    20G   15G  4.6G  77% /home/paul
$ df -i /tmp/ /home/paul
Filesystem            Inodes   IUsed   IFree IUse% Mounted on
tmpfs                 257065    1800  255265    1% /tmp
hibernia:/home/paul  5155840  163261 4992579    4% /home/paul
$ quota -s paul
..
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
hibernia:/home/paul
                  6291M   9668M  11670M            122k    180k    169k        

I tried using gconf to set the /apps/nautilus-cd-burner/temp_iso_dir key to /tmp, but still the same error message.

The error message is uninformative. *what* is the destination? Where is it? If I knew, I could maybe fix the filesystem concerned, except the filesystems all appear to have plenty of space, so maybe it's an actual bug in nautilus-cd-burner in assessing free space. It's impossible to tell either way.

I then ran:

mkisofs -R ~/Desktop/temp/ | cdrecord -v fs=6m dev=/dev/hdc -

Which worked fine.


So:

1. The error message is most definitely uninformative and lacking a key detail (the fs concerned - without which knowledge the problem is impossible to resolve, if the problem is external to nautilus-cd-burner)

2. nautilus-cd-burner possibly has a bug in its logic to assess whether there is sufficient space free (but see 1 - I cant say for sure).

I'm setting this to 'high' because while nautilus-cd-burner does not crash, it is rendered completely unuseable by this bug, when it strikes.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. drag files into cd-creator
2. get error message "not enough space on destination"
3. check that home and /tmp have plenty of space and inodes free, scratch head in bewilderment

Expected Results:  It should have:

1. Told me exactly which filesystem had insufficient space
2. If indeed this fs had enough space (which i think is possibly the case), it should not have produced the error in the first place

Additional info:

Comment 1 Matthew Miller 2006-07-10 20:46:56 UTC
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!


Comment 2 Matthias Clasen 2008-02-04 06:06:35 UTC
Closing now, since too many FC releases have come and gone since this was marked
as NEEDINFO


Note You need to log in before you can comment on or make changes to this bug.