Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156444 - perl packaging problems
Summary: perl packaging problems
Keywords:
Status: CLOSED DUPLICATE of bug 156288
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-30 11:49 UTC by Martin Braun
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-30 20:22:50 UTC


Attachments (Terms of Use)
messages for rpm --verify and yum update (deleted)
2005-04-30 11:52 UTC, Martin Braun
no flags Details

Description Martin Braun 2005-04-30 11:49:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
After installing Fedora Core 3 (x86_64) I found that
perl rpms for x86_64 and i386 are present on my system
(this is probably normal).
`rpm -q --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" perl'
perl-5.8.5-9.i386
perl-5.8.5-9.x86_64

Running `rpm --verify' on both packages shows that the same
files were installed by both packages causing verification errors.
A more serious problem is that perl can not by updated by yum for two
reasons:
1) only x86_64 version gets updated
2) update fails because of conflicting files

(see attached log)

Perl documentation and scripts should be moved to a noarch
package.

Version-Release number of selected component (if applicable):
perl-5.8.5-9, perl-5.8.5-11.FC3

How reproducible:
Always

Steps to Reproduce:
1.rpm --verify perl-5.8.5-9.x86_64
2.rpm --verify perl-5.8.5-9.i386
3.yum update
  

Actual Results:  1) no output
2) error messages (checksum and timestamp errors)
3) update failure because of conflicting files

Expected Results:  1) no output
2) no output
3) update success

Additional info:

Comment 1 Martin Braun 2005-04-30 11:52:37 UTC
Created attachment 113886 [details]
messages for rpm --verify and yum update

Comment 2 Warren Togami 2005-04-30 20:22:50 UTC
Unfortunately we made a mistake with the original FC3 x86_64 and shipped i386
perl by accident when it was never meant to be multilib.  The only way to
recover is to use 'yum remove perl.i386'.

Sorry about the inconvenience.

*** This bug has been marked as a duplicate of 156288 ***


Note You need to log in before you can comment on or make changes to this bug.