Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156430 - Installer doesn't support InfiniBand
Summary: Installer doesn't support InfiniBand
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-30 00:36 UTC by Tom Duffy
Modified: 2012-01-24 15:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-24 15:31:09 UTC


Attachments (Terms of Use)

Description Tom Duffy 2005-04-30 00:36:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041218 Epiphany/1.4.8

Description of problem:
ib_mthca (the IB low level driver) is autoloaded on boot, but the IP network driver (ib_ipoib) is not.  Therefore, no ib* network devices are created and I cannot set it up.

If I manually (after install), edit my modprobe.conf and add:

alias ib0 ib_ipoib

Also, create the appropriate /etc/sysconfig/network-scripts/ifcfg-ib0, I can get it to come up on boot.

The installer should take of this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try to install a system with an IB card
2. no offer to configure ib* devices
3. doesn't boot with ib_ipoib enabled
  

Additional info:

Comment 1 Jeremy Katz 2005-05-05 21:24:06 UTC
This looks a little bit ... horky.  Why is the PCI device associated with the
low-level driver and not the network driver?

Also, without hardware, it's not likely that we're going to really do much in
this area without explicit patches.

Comment 2 Tom Duffy 2005-05-05 22:34:47 UTC
I meant this bug as more of a placeholder.

In any event, IB is not an IP device.  The low level driver just initializes the
hardware for all upper level protocols.  IPoIB allows you to run IP services on
top of InfiniBand.

Analogous to the mptbase and mptscsih code, you need the low level driver which
allows multiple users as separate modules.

I was planning on diving into the installer code at some point to see how hard
it would be to add in support, but have not had the time.

Comment 3 Bug Zapper 2008-04-03 16:07:41 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 4 Shawn Starr 2008-04-24 01:12:36 UTC
Hi Tom, I've also liked the idea of IB support for Anaconda, there's some
outstanding issues though one big one is ISC DHCP does not support IB networking
right now. OFED has a patch but they have not given it to them and without this
you could not use PXE kickstart installation with Fedora.

We need the ib udev rules added to the initramfs, to Anaconda it shouldn't
really matter as long as Anaconda determines it is a network device like any
ethernet but there might be some code to add to create the ifcfg entries for
ib#.

Shawn.

Comment 5 Shawn Starr 2008-04-24 01:13:47 UTC
You would also need OpenSM if the hardware doesn't have an sm. OpenSM is not
packaged with Fedora at this time since it comes from OFED (OpenIB).

Comment 6 Chris Lumens 2008-08-27 16:52:53 UTC
I'm happy to review any infiniband patches you care to submit, but we have neither the hardware nor the expertise at the moment to really dive into this and make it work.

Comment 7 Shawn Starr 2008-12-11 00:02:14 UTC
Please don't close this. At least provide a reason.

Comment 8 Chris Lumens 2008-12-12 00:16:00 UTC
I think there were plenty of reasons in comment #6:

(1) We don't have any hardware, so we couldn't do this even if we wanted to.
(2) To the best of my knowledge, no one who works on anaconda has the expertise for this so doing it is going to take a long time to ramp up knowledge.
(3) We simply do not have enough time right now to work this up.  The fact that this bug has also been opened three years with no change in our availability means it's extremely unlikely that we will have the time in the future as well.
(4) Very low interest - there's only two people who have shown interest in this bug report in those same three years, which means it's not likely that the time investment is going to yield a very big return.

Now, I would be happy to review any patches that anyone is willing to contribute, but I doubt we're going to be able to work on it ourselves.  I figured that closing a bug we're never going to otherwise fix was probably a more polite approach than leaving it to stagnate and keep people's hopes up.  However if you'd like to leave it open, I guess we can do that too.  Just keep in mind little is expected to change here without an outside push to help it happen.

Comment 9 Shawn Starr 2008-12-12 16:12:03 UTC
Well, if I'm going to do the work. I'd want the bug open so I don't forget about this.

Comment 10 Chris Lumens 2008-12-12 16:16:48 UTC
Shawn - okay, sounds good.  I just want to state that I'm not opposed to adding the support for this.  I just know I'm never going to get around to it.  However I'll gladly review patches and apply them assuming they pass review on anaconda-devel-list.  Thanks for reassigning this one.

Comment 11 Shawn Starr 2012-01-02 20:50:14 UTC
Priorities shifted, *I* don't have InfiniBand hardware anymore...so if someone else wants to implement feel free.


Note You need to log in before you can comment on or make changes to this bug.