Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156419 - Openoffice requires Java, but isn't pulled in as a dep
Summary: Openoffice requires Java, but isn't pulled in as a dep
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-04-29 22:33 UTC by Kyrre Ness Sjøbæk
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-05-24 14:04:04 UTC


Attachments (Terms of Use)

Description Kyrre Ness Sjøbæk 2005-04-29 22:33:39 UTC
Description of problem:
I did a Rawhide "workstation" install 29. April 2005, and wanted to see the new
OpenOffice. Looked great (but where did that left vertical bar go? I loved that
thing!), but starting base revealed a serious problem - it needed a JRE (no
suprise) that was not installed (suprise).

On startup it spewed out an error:
javaldx: could not find a Java runtime enviroment!

It runs, but after you create a new database the program periodically spews out:
OpenOffice requires a JRE (...) Please install a JRE (...)
And it is a bit dysfunctional.

Version-Release number of selected component (if applicable):
openoffice.org-*-1.9.96-2

How reproducible:
Every time

Steps to Reproduce:
1.Start openOffice
2.Watch the error messages
3.
  
Actual results:
JRE dep is lacking. 

Expected results:
Should have a JRE dep, as it needs it...

Additional info:
It seems like this is also hurting startup time, as it runs a prosess called
"gij" (and later, javadlx) for a long time before actually starting.

Comment 1 Caolan McNamara 2005-05-03 07:26:30 UTC
> rpm -qRp openoffice.org-core-1.9.96-2.i386.rpm | grep gcj
libgcj >= 4.0.0
libgcj.so.6
This should be sufficient to require gcj/gij which should be sufficient to
replace java. Clearly something is not working, works for me of course so
perhaps there is an extra requirement.

Comment 2 Kyrre Ness Sjøbæk 2005-05-03 16:03:33 UTC
I did a clean rawhide install april the 30th - downloaded the entire rawhide
three from ftp.nluug.nl. Still have the copy if you want a ls -lR of it.

Installed a standard workstation install from the text-mode installer, selected
no  installer language and keyboard.

Maybe this is really an anaconda bug that should be seen together with OO bug
nr. 156423?

Anyway it does seem that i have libgcj-4.0.0-2 installed...

Comment 3 Kyrre Ness Sjøbæk 2005-05-05 22:06:39 UTC
Is there anything i should try to yum in, just to test? Anything? This is a
testing rig, so just tell me what to do, reinstall if neccessary.

Comment 4 Kyrre Ness Sjøbæk 2005-05-05 22:31:33 UTC
BTW. openoffice-*-1.9.100-1 doesn't fix this.

Comment 5 Kyrre Ness Sjøbæk 2005-05-06 09:39:26 UTC
I did a "yum install eclipse", which pulled theese rpms:

Installing:
 eclipse-platform        i386       1:3.1.0_fc-0.M6  development        42 M
Installing for dependencies:
 ant                     i386       1.6.2-3jpp_5fc   development       2.0 M
 ant-antlr               i386       1.6.2-3jpp_5fc   development        20 k
 ant-apache-bcel         i386       1.6.2-3jpp_5fc   development        23 k
 ant-apache-log4j        i386       1.6.2-3jpp_5fc   development        18 k
 ant-apache-oro          i386       1.6.2-3jpp_5fc   development        61 k
 ant-apache-regexp       i386       1.6.2-3jpp_5fc   development        18 k
 ant-apache-resolver     i386       1.6.2-3jpp_5fc   development        18 k
 ant-commons-logging     i386       1.6.2-3jpp_5fc   development        19 k
 ant-jdepend             i386       1.6.2-3jpp_5fc   development        27 k
 ant-jmf                 i386       1.6.2-3jpp_5fc   development        15 k
 ant-jsch                i386       1.6.2-3jpp_5fc   development        35 k
 ant-junit               i386       1.6.2-3jpp_5fc   development        88 k
 ant-nodeps              i386       1.6.2-3jpp_5fc   development       375 k
 ant-swing               i386       1.6.2-3jpp_5fc   development        18 k
 ant-trax                i386       1.6.2-3jpp_5fc   development        86 k
 antlr                   noarch     2.7.4-2jpp_1fc   development       296 k
 bcel                    noarch     5.1-1jpp_4fc     development       456 k
 classpathx-jaf          noarch     1.0-2jpp_3fc     development        57 k
 classpathx-mail         noarch     1.0-3jpp_1fc     development       252 k
 eclipse-ecj             i386       1:3.1.0_fc-0.M6  development       6.7 M
 gcc-java                i386       4.0.0-2          development       2.3 M
 gjdoc                   i386       0.7.4-4          development       1.1 M
 gnu-crypto              noarch     2.0.1-1jpp_3fc   development       606 k
 gnu-crypto-jce-jdk1.4   noarch     2.0.1-1jpp_3fc   development       111 k
 gnu-crypto-sasl-jdk1.4  noarch     2.0.1-1jpp_3fc   development        31 k
 jakarta-commons-beanut  i386       1.7.0-1jpp_2fc   development       402 k
 jakarta-commons-collec  i386       3.1-1jpp_2fc     development       1.0 M
 jakarta-commons-digest  i386       1.6-2jpp_2fc     development       395 k
 jakarta-commons-loggin  i386       1.0.4-2jpp_2fc   development       188 k
 jakarta-commons-modele  i386       1.1-3jpp_2fc     development       303 k
 java-1.4.2-gcj-compat   i386       1.4.2.0-40jpp_1  development        14 k
 java-1.4.2-gcj-compat-  i386       1.4.2.0-40jpp_1  development        14 k
 jdepend                 noarch     2.6-2jpp_3fc     development       197 k
 jessie                  noarch     1.0.0-6          development       348 k
 jsch                    i386       0.1.18-1jpp_1fc  development       332 k
 junit                   noarch     3.8.1-3jpp_4fc   development       179 k
 jzlib                   noarch     1.0.5-2jpp_1fc   development        35 k
 libgcj-devel            i386       4.0.0-2          development       1.0 M
 libswt3-gtk2            i386       1:3.1.0_fc-0.M6  development       5.2 M
 log4j                   noarch     1.2.8-7jpp_3fc   development       304 k
 mx4j                    i386       1:2.1.0-1jpp_5f  development       1.9 M
 oro                     noarch     2.0.8-1jpp_2fc   development        72 k
 regexp                  noarch     1.3-1jpp_4fc     development        30 k
 xalan-j2                noarch     2.6.0-2jpp_1fc   development       1.7 M
 xml-commons             i386       1.0-0.b2.6jpp_1  development        18 k
 xml-commons-apis        i386       1.0-0.b2.6jpp_1  development       257 k
 xml-commons-resolver    noarch     1.1-1jpp_4fc     development        61 k

After that, the problem went away. So some of the rpms mentioned here is needed :)

Comment 6 Kyrre Ness Sjøbæk 2005-05-11 20:08:33 UTC
Still a problem on FC4-t3. Installation type "personal desktop".

This should definatly be fixed before fc4 final is released to the open -
FC4Target or FC4Blocker?

Comment 7 Warren Togami 2005-05-11 20:16:19 UTC
EasyFix that we should do, but find the exact req's.

Comment 8 Per Bjornsson 2005-05-11 20:37:35 UTC
One simple possibility might be that OOo migth depend on the specific paths etc.
Isn't java-1.4.2-gcj-compat the package that should fix that? Kyrre, since you
seem to have a broken system available, perhaps you can install just that
package additionally and see if it works?


Comment 9 Kyrre Ness Sjøbæk 2005-05-11 21:48:40 UTC
yup, that solved it. Note that java-1.4.2-gcj-compat brougth in a whole lot of
deps. Btw. - why "compat"?

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 java-1.4.2-gcj-compat   i386       1.4.2.0-40jpp_1  development        14 k
Installing for dependencies:
 gcc                     i386       4.0.0-4          development       2.6 M
 gcc-java                i386       4.0.0-4          development       2.3 M
 gjdoc                   i386       0.7.4-5          development       1.1 M
 glibc-devel             i386       2.3.5-6          development       2.0 M
 glibc-headers           i386       2.3.5-6          development       592 k
 glibc-kernheaders       i386       2.4-9.1.94       development       706 k
 gnu-crypto              noarch     2.0.1-1jpp_3fc   development       606 k
 gnu-crypto-jce-jdk1.4   noarch     2.0.1-1jpp_3fc   development       111 k
 gnu-crypto-sasl-jdk1.4  noarch     2.0.1-1jpp_3fc   development        31 k
 jessie                  noarch     1.0.0-6          development       348 k
 libgcj-devel            i386       4.0.0-4          development       1.0 M
 zlib-devel              i386       1.2.2.2-3        development        98 k


Comment 10 Warren Togami 2005-05-11 22:00:09 UTC
If possible we really need to avoid cases where a normal user installation
requires *-devel or compilers to be installed.  Find the *exact* deps necessary.

Comment 11 Hans de Goede 2005-05-12 06:06:24 UTC
I have seen this bug too, esp the startup delay is annoying. Couldn't it be that
the exact dep is java-1.4.2-gcj-compat, this provides jre / jdk mimicking
scripts. Maybe java-1.4.2-gcj-compat should be split in a jre and jdk part (or
java-1.4.2-gcj-compat and java-1.4.2-gcj-compat-devel)?




Comment 12 Kyrre Ness Sjøbæk 2005-05-12 13:41:45 UTC
To me "*-devel" indicates header files...

Comment 13 Thomas Fitzsimmons 2005-05-18 22:33:37 UTC
Unfortunately, JPackage deviated from this convention for the SDK packages. 
java-1.4.2-gcj-compat contains the "JRE" parts and java-1.4.2-gcj-compat-devel
contains the "SDK" parts minus the "JRE" parts.  There was a bogus dependency on
gcc-java in java-1.4.2-gcj-compat (the JRE package), which is fixed in
java-1.4.2-gcj-compat-1.4.2.0-40jpp_22rh.  This should minimize the dependencies
brought in by the base java-1.4.2-gcj-compat package.

Comment 14 Jeremy Katz 2005-05-23 23:22:39 UTC
So all we need is the requires added to OOo now?  If so, let's get that in.

Comment 15 Dan Williams 2005-05-24 02:00:37 UTC
Ok, I'll add a Requires on java-1.4.2-gcj-compat to the final build then.

Comment 16 Dan Williams 2005-05-24 14:04:04 UTC
Should be fixed in current rawhide.


Note You need to log in before you can comment on or make changes to this bug.