Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156392 - cdrom drives disappeared after installing new harddrive
Summary: cdrom drives disappeared after installing new harddrive
Keywords:
Status: CLOSED DUPLICATE of bug 116096
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-29 17:31 UTC by Stig Nielsen
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-30 23:27:38 UTC


Attachments (Terms of Use)

Description Stig Nielsen 2005-04-29 17:31:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
cdrom drives disappeared after installing new harddrive (Enable SATA controller in BIOS and creating filesystems), along with /dev/hdc, /dev/hdd, /dev/cdrom, /dev/cdrom1, /mnt/cdrom etc.

Here's the new /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/md0                /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/md2                /home                   ext3    defaults        1 2
LABEL=/mnt/backup       /mnt/backup             ext3    defaults,noauto 1 2
LABEL=/opt              /opt                    ext3    defaults        1 2
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/md1                /usr                    ext3    defaults        1 2
/dev/sdb1               swap                    swap    defaults        0 0
/dev/sda1               swap                    swap    defaults        0 0

(the new harddisk /dev/sdc1-4 has not been added but works perfectly mounting it manually)

Here's /etc/fstab before the problem (working OK):
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/md0                /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/md2                /home                   ext3    defaults        1 2
LABEL=/mnt/backup       /mnt/backup             ext3    defaults,noauto 1 2
LABEL=/opt              /opt                    ext3    defaults        1 2
none                    /proc                   proc    defaults        0 0
none                    /sys                    sysfs   defaults        0 0
/dev/md1                /usr                    ext3    defaults        1 2
/dev/sdb1               swap                    swap    defaults        0 0
/dev/sda1               swap                    swap    defaults        0 0
/dev/hdd                /media/cdrom            auto    pamconsole,fscontext=system_u:object_r:removable_t,ro,exec,noauto,managed 0 0
/dev/hdc                /media/cdrecorder1      auto    pamconsole,fscontext=system_u:object_r:removable_t,ro,exec,noauto,managed 0 0
/dev/fd0                /media/floppy           auto    pamconsole,fscontext=system_u:object_r:removable_t,exec,noauto,managed 0 0

I tried overwriting /etc/sysconfig/hwconf with the original one as well but with no effect.
Tried running kudzu again - no luck

I'm not what to give you for additional information, nor if kudzu is the problem -  please let me know. 


Version-Release number of selected component (if applicable):
kudzu-1.1.95-1

How reproducible:
Didn't try

Steps to Reproduce:
1.Install Harddisk
2.enable SATA controller
3.boot (new hardware found and configured OK)
  

Actual Results:  No removable drives available, 


Expected Results:  My removable drives should not be affected 

Additional info:

Q: To reproduce, how can I set the system back to what it was initially? (I have backed up old /etc)

I've seen it before on RH9 - though by installing other HW

Comment 1 David Zeuthen 2005-04-29 18:36:32 UTC
Please include the info requested on this page

 http://freedesktop.org/wiki/Software_2fHalTraces

Also include the output of 'tree /sys' (you may need to install the 'tree'
package for the 'tree' command).

Comment 2 Stig Nielsen 2005-04-30 23:27:38 UTC
Thanks for the links/hints. Doing a bit more research I found that the problem
is due to hardware limitations related to Soyo SY-P4I875P DRAGON 2

http://www.soyogroup.com/kb/kbdesc.php?id=160

"When using a non Windows XP system, only 4 harddisks/IDE devices are supported
at the same time on IDE 1,2 and SATA 1,2. Windows XP systems can support all 6
devices on these ports (2 SATA, 4 parallel ATA/ATAPI devices)."


*** This bug has been marked as a duplicate of 116096 ***


Note You need to log in before you can comment on or make changes to this bug.