Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 156388 - libstdc++-v2 backwards compatibility librarys are not available
Summary: libstdc++-v2 backwards compatibility librarys are not available
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: compat-egcs
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-29 17:02 UTC by Brian Nelson
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-30 07:39:08 UTC


Attachments (Terms of Use)

Description Brian Nelson 2005-04-29 17:02:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
The old libstdc++-v2 libs appear to not be available under RHEL4. The compat-libstdc++ package is now split into a v296 package and a v33 package. There is no package containing the older files (egcs libs from RH 6.x):

/usr/lib/libg++.so.2.7.2.8
/usr/lib/libstdc++.so.2.7.2.8
/usr/lib/libstdc++.so.2.8.0
/usr/lib/libstdc++.so.2.9.dummy

In my case, libstdc++.so.2.8 is needed by RealServer 8.

I did notice that FC3 has a package (compat-libc++std-8) that contains these files. Since FC4 and RHEL4 use the same kernel/gcc, I don't see why RHEL would not have a similar package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Files missing/not available as installed
2.
3.
  

Additional info:

Comment 1 Jakub Jelinek 2005-04-30 07:39:08 UTC
These were removed on purpose, we don't want to maintain all ever existing
compatibility libstdc++ libraries forever.  libstdc++.so.2.8.0
is I believe egcs 1.0.3, i.e. 7 years old compiler, which doesn't
build on RHEL4 without a big effort.  You are free to copy that library from
older systems.


Note You need to log in before you can comment on or make changes to this bug.